Support » Plugin: Site Kit by Google » Error on “Sign in with Google”

  • Resolved harrisonprice

    (@harrisonprice)


    Hi, I’ve installed the Site Kit plugin from the WordPress Plugin repository, I have the latest version of WP, PHP7.3 and the plugin and when i click on Sign in with Google, I get the following error:

    An error occurred: We are unable to send credentials to your WordPress site. This is likely due to your hosting provider blocking incoming REST API requests. Please check with them if that is the case.

    I’ve spoken to my hosting and have had no joy with this.

    Any help is greatly appreciated.

    FYI, I have disabled all plugins and changed to the TwentyNineteen theme but have had no luck with it.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Support James Osborne

    (@jamesosborne)

    @harrisonprice If incoming REST API requests are blocked or restricted at host level Site Kit may not be able to function. Can you add the following to the end of your website URL to check if there is any response:
    /?rest_route=/

    Out of curiosity what hosting provider are you using?

    @jamesosborne Thanks for the reply. I’ve added that to the end of the domain https://maysphotography.co.uk and brings up a page.

    I’m using TSOHost as my hosting provider

    Plugin Author Thierry Muller

    (@tweetythierry)

    Thanks @harrisonprice for reporting this issue. We will spin up on site on TSOHost, do some testing on our side and get back to you asap with our findings.

    Thanks,

    harrisonprice

    (@harrisonprice)

    @tweetythierry If it helps, the outgoing cloud IP is 91.208.99.2

    Plugin Author Thierry Muller

    (@tweetythierry)

    @harrisonprice we just pushed a fix which solve this issue now. Could you give it another try and let us know?

    Hello @tweetythierry,

    I made the update and I still got the same error!

    However, it’s my fault …

    Indeed, I am creating my site WP and, meanwhile, I set up an index.php page that serves as a temporary front and redirects all flows to a page “coming soon”.

    After turning off the facade, I was able to set up Google Site without problems.

    Thank you 🙂

    I publish this answer because other users may have done the same thing as me.

    Attention, I do not answer for @harrisonprice but only for my case.

    Regards,

    I am getting the same issue without “coming soon” enabled. The site is already registered on Google Search console.

    My host wants to know the IP address that is being requested from the plugin.

    @tweetythierry thierry please help me, brother, I am facing the same problem bro, my site is godoffunk.ga and my host is infinity free. I installed the google site kit but when I try to sign in it shows me this

    “An error occurred: We are unable to send credentials to your WordPress site. This is likely due to your hosting provider blocking incoming REST API requests. Please check with them if that is the case”

    i don’t know what to do

    Plugin Support Renee Johnson

    (@reneesoffice)

    Thanks for the updates! @westerdaled and @godoffunk could you open new topics referencing who your host is and if possible confirm that incoming REST API and POST requests are not being blocked there?

    Also having the same issue. I am able to get to the /?rest_route=/ no problem (even when testing from Google Page Insights – https://developers.google.com/speed/pagespeed/insights/?url=)

    CDN: Cloudflare (which we do have a bunch of ASNs blocked for things like Amazon, GoDaddy and other hosts that should not be sending us traffic essentially – basically we’ve found that traffic from those type of providers normally are just scanning for vulnerabilities or attempting hacking, or scanning our sites to see what they can sell about us)
    Host: Namehero

    Also, nothing is showing in the firewall logs for CF or Wordfence… but curious, is there a specific IP address(es) that should be whitelisted?

    @tweetythierry with the 1.3 update, I can now use Site Kit. Thank you

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.