• Hi there,

    i just installed and setup my first ninjaform. On testing i get this error between the lines of the form:

    Warning: Invalid argument supplied for foreach() in .../wp-content/plugins/ninja-forms/includes/fields/calc.php on line 836

    No error in prewiew mode

    Please help ?
    Thank you,
    B

    https://wordpress.org/plugins/ninja-forms/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Well i know this is a free plugin, but a BUG is still a BUG.
    Can someone at least point some direction for solving this errors ?
    Thanx,
    B.

    So i set it to hide the form after submission so the error is not visible. Is there another way ?

    Hi

    You can try disabling WP_DEBUG in wp-config.php file
    It will hide all warning and notices.

    define(‘WP_DEBUG’, false);

    Hey, thank you for the answer and i’m glad to see i’m not alone here.

    Disabling/hidding the error warnings is not the best option.

    Now i enabled the form to send me an email notification every time someone someone successfully sends a form.

    Now, after submit i get another 2 messages:
    Warning: strpos() expects parameter 1 to be string, array given in …/wp-includes/shortcodes.php on line 189

    Warning: preg_match_all() expects parameter 2 to be string, array given in …/wp-content/plugins/ninja-forms/includes/shortcode.php on line 153

    This plugin has too many bugs.

    Plugin Contributor Zachary Skaggs

    (@wpnzach)

    As a reminder from our sticky on this forum, all support requests should be directed here: https://ninjaforms.com/contact/

    That form will walk you through gathering additional needed data to troubleshoot your issue and provide much faster support. These forums are not actively monitored by our support team.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Error on sending’ is closed to new replies.