Support » Plugins and Hacks » [Resolved] Error on restore

[Resolved] Error on restore

  • Hello,
    Hope you can help me out. I tried to migrate…
    the backup went all good but with the restore on the new wordpress installation i get this error:

    Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 139129427 bytes) in /var/www/vhosts/rubencreemers.nl/subdomains/wp/httpdocs/wp-admin/includes/file.php on line 640

    Looks like it has something to do with insufficient space..is that right?
    This is the first time i’m moving a WP-website and i’m kinda new to all of this. Could you please help me out or maybe point me in the right direction?..The destination server should have more than enough free space…
    It also looks like it started migrating ok, lots of files have been tranferred but obviously something went wrong during migration..
    Hope to hear from you soon..
    Thanks in advance..


Viewing 11 replies - 1 through 11 (of 11 total)
  • Moderator Jan Dembowski


    Side note: thanks for starting your own topic, I really appreciate it. 😉

    Looks like it has something to do with insufficient space..is that right?

    Well, it’s really about insufficient available RAM to your PHP interpreter on your web server. That’s a ton of memory already allocated already but on the system you are trying to restore on try allocating even more.


    You may need to increase that via your web server’s php.ini file. Look for the memory_limit = line there and make that number bigger.

    Before you edit any files on your web server please make sure you have a backup first. That way if you make a mistake editing (it’s easy to do) you can just put back the copy you made.

    If none of that works then you may want to follow the instructions in the Moving WordPress codex article instead. In your case you’d be following those instructions as if you were moving to another server.

    Hi Jan,

    Thanks for your quick response!. I found the php.ini file on my new location and changed the line to a higher value but still i get the same error message. i changed it to 600M and 600 mb. (it was 48M and 16mb, so that’s quite an increasement.) I’m not sure what i’m doing / doing wrong. Also i don’t quite understand what you were saying about the ton of memory.

    About the backup…we are talking about changing the php.ini file on my NEW location, not in the one i’m trying to move, right?

    The link you send concerning “moving wordpress (to another server) i allready found earlier, but that was too confusing for me..that’s why i was so glad/hopefull after finding your plugin..
    Any other suggestions on how to make this plugin work?

    Thanks again…

    Moderator Jan Dembowski


    I found the php.ini file on my new location and changed the line to a higher value but still i get the same error message.

    When you make changes to that file you have to restart your Apache web server or the change doesn’t take effect. Give that restart a try, 600M is huge. 😉

    Thank you so much again for your response..I’ sorry, i’m really new to all of this..
    Where/how can i restart this apache server? don’t where to look/start..
    Is there a way to tell me how or would this just take to much explenation..
    Plz let me know..thanks..

    ..and, so 600M is over the top right?

    Moderator Jan Dembowski


    I’m sorry, i’m really new to all of this..

    It’s all good, asking here is a good way to pick this up.

    Where/how can i restart this apache server?

    Do you know what kind of web server is it? On my installation I use Ubuntu LTS 12.04.2 so that would be this on the command line.

    sudo service apache2 restart

    But if you’re not running Ubuntu then that may not work for you.

    Plugin Author WP Academy


    looks like it’s running out of RAM when extracting the zip file,try these;
    click the ‘advanced settings’ link,check the ‘alternate zip method’ and then click restore,that probably should work.
    but assuming that it didn’t,enter something greater than 512 into the ‘max memory limit’ [eg: 600,700 or even 1024 (1024 = 1 gig)] field before you click restore.
    and even if that didn’t work,do a database only backup and use that to do the restore. (you’ll have to manually copy the content of the ‘wp-content’ directory from your origin site to the destination site before doing the restore)

    Thanks alot for your responses.. i really appriciate it!
    I’m going to try and work this out as soon as i can i then i’ll let you know if i managed to get it working…
    Thanks Agin

    Hello Again!
    The alternate Zip-method worked.!!.thank you so much! (I eventually never got to the restart of the apache server…cause i didn’t knew how exactly. )
    But the migration worked fine all the files seem to be in the right place. One problem though..when trying to updating my theme with the integrated upload-function, or upload a new file, i get the message:
    “Can’t create the folder uploads/2013/08. Is the folder above writable by the server?”

    It seems like there’s a permission/rights-problem to write to the upload folder. I probably have to change something manually. Writing directly to the folder through ftp does work however, so it has to be something inside the wordpress-settings, maybe?

    Looking forward to your reply again!

    Iv’e opened a new topic also..but i’m not getting any response..
    Can someone please help me out or point in the right direction?
    like i wrote above:
    I can’ t write/upload anything to my new installation using the upload function within WP after migrating through the WP-Clone- plugin. I’ve tried to change the writing-permission of the folder on the server via ftp, but still the problem remains…
    Hope someone can help me out.

    Plugin Author WP Academy


    sorry about that,I wasn’t around to respond to these threads.
    anyways,seems to me that it’s more relevant to continue this on your other thread so I’ll just mark this as solved.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Error on restore’ is closed to new replies.