Support » Installing WordPress » Error on Publishing Posts

  • Resolved ksd823


    After upgrade to 2.0.6 the following occurs.

    When a published post is edited then saved the following error message is displayed.

    WordPress database error: [Lost connection to MySQL server during query]
    INSERT INTO wpdb_postmeta (post_id,meta_key,meta_value) VALUES ('87','_pingme','1')
    Warning: Cannot modify header information - headers already sent by (output started at /blogdirectory/wp-includes/wp-db.php:104) in /blogdirectory/wp-includes/pluggable-functions.php on line 270

    This occurs no matter if the post is a new (post upgrade) post or a old (pre-upgrade) post. Posts can be created and saved as draft without the error, however when the status is changed to Published and the post saved the error occurs.

    With the changes I have tested the change appears to stick in the database regardless of the error (example: Change the ping status of the post and save, the error occurs, however when going back to the post through the wp-admin interface the ping status is changed as requested.)

    Any thoughts? To date I have reinstalled the wp code by a full delete of all folders except wp-content and wp-config.php and reinstalled to guard against any ftp upload corruption.

    Thanks in advance for any ideas on a next step.

    Kevin (ksd823)

Viewing 6 replies - 1 through 6 (of 6 total)
  • It really sounds like a plugin conflict. Have you activated any lately?

    I added the GeoPress plugin and Inline Google Maps plugin at different times today – but had disabled both before noticing this problem.

    However – your question does cause me to rethink the chronology – calling this a 2.0.6 upgrade problem is likely unfair as I do think that I edited at least one post after upgrading but before noticing the problem.

    I see that GeoPress added a table. Other than a disable – what should I do.

    As a reference – here is a list of all plug-ins and plug-in versions with their current status.

    Akismet 1.2.1 Active
    Contact Form ][ 2.0.13 Active widget 1.0 Not Active
    EzStatic 3.1.1 Not Active
    GeoPress 2.3 Not Active
    Google Search widget 1.0 Active
    Hello Dolly 1.5 Not Active
    Inline Google Maps 1.1 Not Active
    Linkblock widget 1.0 Active
    Markdown 1.0.1 Not Active
    Role Manager 1.4.3 Active
    Sidebar Widgets 1.0.20060711 Active
    Textile 1 1.0 Not Active
    WordPress Database Backup 1.8 Active
    WPG2 2.0 Active
    wpg2block widget 1.0 Active

    Personally, I would just deactivate the most recent one(s) one at a time for a quick look and see if the problem still exists.

    Done – I re-enabled GeoPress then re-disabled it. Same with Inline Google Maps.

    Each time I went to my test post and tried to just save it with no changes. I got variations of the initial message talking about inserts into the postmeta table.

    Looking at that table in MySQL all seems to be ok. I can manually run the insert string presented in the error message, so no problem there.

    Is there some type of DB check utility that makes sure that the wp tables are sane?

    Your host should have one to do it through phpmyadmin.
    Also this very good plugin will do it.

    Thanks – I will check that out – it looks handy.

    BTW – I kept playing around continuing to enable and disable the plug in and all of a sudden – it worked.

    Not sure why – one of the register / unregister routines must have finally reset something.

    Thanks for your help – I am going to mark this one resolved – even if puzzled would be more appropriate 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Error on Publishing Posts’ is closed to new replies.