WordPress.org

Forums

Register Plus Redux
[resolved] Error on plugin activation (8 posts)

  1. zeoez
    Member
    Posted 1 year ago #

    Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected '{' in /home/content/html/wp-content/plugins/register-plus-redux/rpr-login.php on line 1

    http://wordpress.org/plugins/register-plus-redux/

  2. silostudios
    Member
    Posted 1 year ago #

    any luck with finding a solution to this error? i just receive the same error on trying to install. :/

    thanks,
    scott

  3. kopperwoman
    Member
    Posted 1 year ago #

    I've experienced this same issue. In my case I have had the plug-in up and running for about 7 months and it's worked flawlessly. Yesterday I migrated my WordPress site to a new environment and when I tried to reactivate the plugin I go the same error message the zeoez and silostudios experienced.

    In looking for help I noticed that this post is about the same issue:
    http://wordpress.org/support/topic/changing-server-problem

    The plugin still works fine in the old environment (WP 3.8.1 on Bluehost). The new environment is identical (WP 3.8.1 on Bluehost). The difference seems to me that I activated and had the plugin running on an earlier version of WordPress when I first installed it 7 months ago. Since then I upgraded to 3.8.1 in the old environment without any issues. But in the new environment I'm trying to activate the plugin on 3.8.1. I think the issue must be some incompatibility with 3.8.1.

    As a troubleshooting effort I tried to delete the plugin on the new environment (so I could reinstall it) and it would not delete. The process just hung on a blank page indefinitely.

    Here's my old site, with the plugin active and working: http://stonewallchorale.org/wp-login.php?action=register
    Here's the same site in the new environment, with the plugin not able to be activated: http://69.195.124.153/~stonewc1/wp-login.php?action=register

    I'm very reliant on this plugin, I really think it's fantastic. I hope you'll be able to get this error fixed soon! Please let me know if there is other information that would be helpful in diagnosing the issue. I'm happy to help out in any way.

  4. silostudios
    Member
    Posted 1 year ago #

    I had to delete the folder i uploaded to the server... then i used the web-based search on the backend to download and install and that fixed it for me.

  5. kopperwoman
    Member
    Posted 1 year ago #

    silostudios: did you lose the settings you had in place from your pre-migration site when you deleted the folder?

  6. radiok
    Member
    Plugin Author

    Posted 1 year ago #

    This error crops up from time to time, it's always been a corrupt file. I would delete the plugin and reinstall it. That has seemed to clear it up.

    Previous incarnation of the same problem:
    http://wordpress.org/support/topic/plugin-could-not-be-activated-because-it-triggered-a-fatal-error-71?replies=2

  7. kopperwoman
    Member
    Posted 1 year ago #

    Radiok: life got in the way and I never had the chance to remove this plugin from the back end.

    When I try to delete the plugin from within the WP plug-in area in my dashboard it won't delete. I just get a blank page.

    I know that I need to remove it via FTP from my WordPress directory but before I do that I'd like to have specific instructions. I don't want to accidentally leave a file behind because I plan to reinstall the plug-in after its completely removed and I'm worried an old file will conflict with a new installation.

    Can you tell me specifically what folders I need to look in and what files I need to delete?

  8. netie
    Member
    Posted 9 months ago #

    I've solved this problem by switching 'Transfer Type' from Auto to Binary in FileZilla. It seems that files were transferred in ASCII mode that caused lose of file formatting.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Register Plus Redux
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.