Support » Plugin: Better Font Awesome » error on local server /// easyphp

  • Resolved alfazzz

    (@alfazzz)


    hi,
    got some problem with the last wordpress update 3.9.1 and your fantastic plugin on my local server (easyphp) :

    Warning: sort() expects parameter 1 to be array, null given in E:\Program Files\EasyPHP-DevServer-14.1VC11\data\localweb\projects\marchedessables\wordpress\wp-content\plugins\better-font-awesome\better-font-awesome.php on line 183
    
    Warning: implode(): Invalid arguments passed in E:\Program Files\EasyPHP-DevServer-14.1VC11\data\localweb\projects\marchedessables\wordpress\wp-content\plugins\better-font-awesome\better-font-awesome.php on line 401

    It is because it’s not yet compatible with the last 3.9.1 wordpress ?

    Thank you
    Olivier

    https://wordpress.org/plugins/better-font-awesome/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Mickey Kay

    (@mcguive7)

    Hmmm, I don’t think I changed anything that would have affected things differently in 3.9.1. A few ideas that you may be able to help me troubleshoot though:

    1. BFA attempts to get a remote copy of Font Awesome, which can cause issues if the CDN is temporarily unavailable. Can you please verify that this is still an issue? If it’s not, then it may have just been a temporary connectivity issue.

    2. Some servers don’t allow wp_remote_get(), which is the function that fetches the remote data. I’m working on modifying this plugin to provide alternatives, but in the meantime can you check to make sure your local setup allows for wp_remote_get()?

    Thanks, I’ll get to work on my end and any help you can provide per my questions would be most appreciated. Thanks!

    I will check that on monday at office…thank you 🙂

    Plugin Author Mickey Kay

    (@mcguive7)

    Any update on this one? If so, I’d love to know the answer to a few questions:

    – What is your site URL? You can email me at mickey@mightyminnow.com if you’d prefer not to post here.
    – Who provides your hosting?
    – What version of PHP are you running?
    – Do you use SSL on your site at all (does your URL use https instead of http)?
    – Are you willing to provide me with login credentials to your site to do some debugging?

    Thanks!

    Hi,
    Since i am working on a local server (easyphp dev server 14.1vc11), i can’t give you a url.
    But i’ve updated this morning your plugin, and no more error message…so looks like this is ok now (wordpress 3.9.1).

    I will let you know if you want, if there is problem online when i will upload on the mutualized server i use.

    Thank you for your help.

    Olivier

    Plugin Author Mickey Kay

    (@mcguive7)

    Hi Olivier,

    Thanks for following up on this one! It seems that at least one other user is still getting the error messages, so I want to check in with you and see if this problem is totally resolved or if it still remains. If you’re still encountering the issue, I’ll have a few more questions for you if you’re open to answering. Thanks!

    Hi, no problem
    I will check on monday at office.
    But i had got the error another time after my last post, dońt know if was a problem with cdn server or internal error plugin, i’m temporaly working on another project for now…

    If you want some precise tests, just let me know.

    Plugin Author Mickey Kay

    (@mcguive7)

    Thanks Olivier,

    Truly appreciate the help! Please do let me know what you encounter on Monday.

    And I would love your help debugging this one if possible, since I simply cannot recreate it on my end, no matter how hard I try. What I’d like to do is work on a debugger version of the plugin that will output all plugin variables to see exactly where the issue is arising. If I work on developing the debugger version of this plugin, would you be willing to install and run it for me?

    Plugin Author Mickey Kay

    (@mcguive7)

    In the meantime, while I’m working on my end, it would be helpful if you could temporarily install the following plugin, which will allow you to easily send me some info about your server setup: http://wordpress.org/plugins/send-system-info

    You can send it to mickey@mightyminnow.com or post it on this thread. Thanks!

    Hi,
    i don’t get any errors anymore, on local server or distant server (ovh), so i think it was a problem with the connection to the cdn server (on my side or their side, my connection is pretty aleatory…).

    Do you still want the infos about my server ?

    Plugin Author Mickey Kay

    (@mcguive7)

    Great, thanks a TON for this info. Very helpful. If you don’t mind I would still like your server info, if it’s not too much trouble. Thanks Olivier!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘error on local server /// easyphp’ is closed to new replies.