WordPress.org

Forums

Displet RETS / IDX Plugin
[resolved] Error on load (12 posts)

  1. NetAlien
    Member
    Posted 2 years ago #

    Just found and installed this plugin. Dropped in my IDX link and added [DispletFrame] to a test page. Left most of the other settings.
    Dashboard now shows Displet Tools {DispletReader, Displet IDX}.
    Hoewver, both the test and Displet IDX pages simply return "Error on Load."
    Uninstalled & re-installed. Something (found nothing in SQLDB) is now preventing a fresh install... back at the above problem.
    Not a very good start.

    http://wordpress.org/extend/plugins/displetreader-wordpress-plugin/

  2. displetdev
    Member
    Plugin Author

    Posted 2 years ago #

    You're trying to use the paid version without a Displet account. You need to select the free version. Not a very good start.

  3. NetAlien
    Member
    Posted 2 years ago #

    Well... I installed the only version found by WP plugin manager. If you mean that I selected the paid version by entering an IDX link; fair enough. But, the plugin is leaving something on my site, because I can't get rid of the error situation after re-installing a couple of times. ie, no way to get back to a fresh install.
    Thanks

  4. displetdev
    Member
    Plugin Author

    Posted 2 years ago #

    Delete the erroneous IDX link from your settings page & it will take you back to step 1. You can then try the free version. If you want to upgrade to the paid version, you will need to contact us for a RETS API.

  5. NetAlien
    Member
    Posted 2 years ago #

    Maybe I'm not being clear enough...
    (I've already stated this above; but trying again)
    Yes, I added an IDX link to the initial settings page; but...
    1. I completely uninstalled the plugin
    2. Installed it again.
    3. NO settings-only page as on original install -- looks already setup
    4. ANY attempt to access settings page returns "Error in load."
    5. Uninstalled again.
    6. Searched SQL-DB -- no settings/data found for this plugin
    7. Looked for *config* files -- none related to this plugin found
    8. checked wp-config.php -- no settings found
    9. Re-installed. Still skips settings page and looks already setup.
    10. ANY attempt to access settings page returns "Error in load."
    11. Checked browser cookies for wordpress.org and my site -- nothing related to this plugin found.

    Hope that's clear enough now...
    So there is NO way to get at the settings page.

    Any clue as to where to look for whatever isn't removed during uninstall?

  6. displetdev
    Member
    Plugin Author

    Posted 2 years ago #

    You're more than likely missing the settings in step #6, but it's not your responsibility to delete the data there. Let me see if we can replicate the problem. Can you provide the link you added to the Displet setting, and can you provide a screenshot of the error you're receiving?

  7. NetAlien
    Member
    Posted 2 years ago #

    Hope the actual code segment will provide better information than a screenshot...

    <div id="wpbody"><div id="wpbody-content" tabindex="0" aria-label="Main content" style="overflow: hidden;"><div id="screen-meta" class="metabox-prefs"><div id="contextual-help-wrap" class="hidden no-sidebar" aria-label="Contextual Help Tab" tabindex="-1"><div id="contextual-help-back"></div><div id="contextual-help-columns"></div></div></div><style>
    
    @-moz-document url-prefix(){
    	.displetreader.iframe{
    		height: 650px;
    	}
    }
    
        </style><div class="wrap displetreader iframe"><h2>
          Displet IDX
        </h2><iframe width="100%" height="80%" src="http://framing.usamls.net/framing/default.asp?f_id=R%5DVYXXYV%5DR/account">#document<html><head></head><body><div align="center" style="font-weight: bold;padding-top: 10px;">
          Error in Load.
        </div></body></html></iframe></div><div class="clear"></div></div>
          <!-- wpbody-content -->
        <div class="clear"></div></div>
          <!-- wpbody -->
  8. displetdev
    Member
    Plugin Author

    Posted 2 years ago #

    We took the following steps & can't replicate the problem. We did the following:

    1) Installed Displet RETS plugin on a fresh WP install.
    2) Add an erroneous link for the Displet Link - http://badlink.com
    3) Uninstalled the plugin through WP backend - deleted the plugin.
    4) Reinstalled the plugin & activated.
    5) Went back to settings & saw the old settings.
    6) Deleted the erroneous link & was taken back to the free version option.

    I'm not sure what's gone on with your installation, but you could have created the error when digging in your DB. If you delete out all instances of settings with the word "displet" in your DB, you should be fine. However, since you're down the path of modifying your database, we can't really support you any further than that. If you'd like to try out the free version of the plugin on a fresh WP install, you can see how it operates.

    ~EB

  9. displetdev
    Member
    Plugin Author

    Posted 2 years ago #

    You should be able to access the DispletReader page http://screencast.com/t/DriF9u3Q where you can then delete out the erroneous IDX link. From there, it will take you back to the option screen where you can select the free option. If you can't get to that page, you've done something to your DB.

  10. NetAlien
    Member
    Posted 2 years ago #

    I did not change anything in the DB, and there were no displet entries in there. Besides, I only went looking into the DB AFTER the problem showed up -- that's the very reason I ended up checking the DB...
    Plugin is installed & activated; but there are no wp_displet tables which is what I was expecting as in other plugins.

    Time to dig deeper...

    Exported entire DB to my local machine. Found these:
    ([...] = redacted)

    table=wp_options:

    (38, 'active_plugins', 'a:15:{[...]i:4;s:48:"displetreader-wordpress-plugin/DispletReader.php";[...]}', 'yes'),
    (46, 'recently_edited', 'a:5:{i:0;s:111:"/home1/homegeni/public_html/paulettewilliamsrealty/wp-content/plugins/displetreader-wordpress-plugin/readme.txt";i:1;s:151:"/home1/homegeni/public_html/paulettewilliamsrealty/wp-content/plugins/displetreader-wordpress-plugin/displetreader-wordpress-plugin-settings-config.php";i:2;s:118:"/home1/homegeni/public_html/paulettewilliamsrealty/wp-content/plugins/displetreader-wordpress-plugin/DispletReader.php";[...]}', 'no'),
    (39594, '_transient_plugin_slugs', 'a:32:{[...]i:5;s:48:"displetreader-wordpress-plugin/DispletReader.php";[...]}', 'no'),
    (56026, 'displetreader_wordpress_plugin_options', 'a:3:{s:49:"displetreader_wordpress_plugin_option_displet_url";s:0:"";s:54:"displetreader_wordpress_plugin_option_displet_freemium";i:0;s:64:"displetreader_wordpress_plugin_option_displet_activated_freemium";b:0;}', 'yes'),
    (56029, 'displetreader', 'a:35:{s:11:"displet_url";s:66:"http://framing.usamls.net/framing/default.asp?f_id=R%5DVYXXYV%5DR/";s:7:"version";s:5:"1.2.x";s:7:"enabled";b:1;s:13:"rows_per_page";i:10;s:14:"cache_lifetime";i:86400;s:12:"default_sort";s:17:"price_high_to_low";s:19:"default_orientation";s:4:"tile";s:19:"disclaimers_enabled";b:0;s:10:"disclaimer";s:0:"";s:11:"remove_link";s:2:"no";s:16:"price_navigation";s:3:"yes";s:24:"property_type_navigation";s:3:"yes";s:22:"comments_debug_enabled";b:1;s:18:"displet_pro_search";b:0;s:22:"ondisplet_landing_page";s:3:"568";s:5:"stats";s:3:"yes";s:18:"show_pending_count";s:2:"no";s:3:"map";s:3:"yes";s:8:"map_hide";s:3:"yes";s:20:"map_latlong_distance";i:2;s:22:"include_listing_office";s:2:"no";s:26:"displet_quick_search_color";s:3:"red";s:19:"include_quick_terms";s:3:"yes";s:21:"include_property_type";s:2:"no";s:13:"include_price";s:3:"yes";s:18:"include_beds_baths";s:3:"yes";s:16:"include_keywords";s:3:"yes";s:34:"displet_quick_search_propertytypes";s:29:""House","Condo","Land","Farm"";s:29:"displet_quick_search_minprice";i:75;s:29:"displet_quick_search_maxprice";i:2000;s:35:"displet_quick_search_priceincrement";i:100;s:28:"displet_quick_search_maxbeds";i:6;s:29:"displet_quick_search_maxbaths";i:6;s:10:"map_height";s:0:"";s:9:"map_width";s:0:"";}', 'yes'),
    (56535, '_site_transient_update_plugins', 'O:8:"stdClass":3:{s:12:"last_checked";i:1359993371;s:7:"checked";a:32:{[...]s:48:"displetreader-wordpress-plugin/DispletReader.php";s:7:"1.5.0.4";[...]}s:8:"response";a:0:{}}', 'yes'),

    table=wp_posts:

    (723, 1, '2013-02-02 19:59:35', '2013-02-03 00:59:35', '[DispletFrame]', 'test', '', 'private', 'open', 'closed', '', 'test', '', '', '2013-02-02 19:59:35', '2013-02-03 00:59:35', '', 0, 'http://paulettewilliamsrealty.com/?page_id=723', 0, 'page', '', 0),
    (724, 1, '2013-02-02 19:59:04', '2013-02-03 00:59:04', ' [DispletFrame]', 'test', '', 'inherit', 'open', 'closed', '', '723-revision', '', '', '2013-02-02 19:59:04', '2013-02-03 00:59:04', '', 723, 'http://paulettewilliamsrealty.com/723-revision/', 0, 'revision', '', 0),

    After uninstalling displet and exporting the DB again...

    table=wp_options:

    (46, 'recently_edited', 'a:5:{i:0;s:111:"/home1/homegeni/public_html/paulettewilliamsrealty/wp-content/plugins/displetreader-wordpress-plugin/readme.txt";i:1;s:151:"/home1/homegeni/public_html/paulettewilliamsrealty/wp-content/plugins/displetreader-wordpress-plugin/displetreader-wordpress-plugin-settings-config.php";i:2;s:118:"/home1/homegeni/public_html/paulettewilliamsrealty/wp-content/plugins/displetreader-wordpress-plugin/DispletReader.php";[...]}', 'no'),
    (152, 'recently_activated', 'a:2:{s:48:"displetreader-wordpress-plugin/DispletReader.php";i:1359997680;[...]}', 'yes'),
    (56026, 'displetreader_wordpress_plugin_options', 'a:3:{s:49:"displetreader_wordpress_plugin_option_displet_url";s:0:"";s:54:"displetreader_wordpress_plugin_option_displet_freemium";i:0;s:64:"displetreader_wordpress_plugin_option_displet_activated_freemium";b:0;}', 'yes'),
    (56029, 'displetreader', 'a:35:{s:11:"displet_url";s:66:"http://framing.usamls.net/framing/default.asp?f_id=R%5DVYXXYV%5DR/";s:7:"version";s:5:"1.2.x";s:7:"enabled";b:1;s:13:"rows_per_page";i:10;s:14:"cache_lifetime";i:86400;s:12:"default_sort";s:17:"price_high_to_low";s:19:"default_orientation";s:4:"tile";s:19:"disclaimers_enabled";b:0;s:10:"disclaimer";s:0:"";s:11:"remove_link";s:2:"no";s:16:"price_navigation";s:3:"yes";s:24:"property_type_navigation";s:3:"yes";s:22:"comments_debug_enabled";b:1;s:18:"displet_pro_search";b:0;s:22:"ondisplet_landing_page";s:3:"568";s:5:"stats";s:3:"yes";s:18:"show_pending_count";s:2:"no";s:3:"map";s:3:"yes";s:8:"map_hide";s:3:"yes";s:20:"map_latlong_distance";i:2;s:22:"include_listing_office";s:2:"no";s:26:"displet_quick_search_color";s:3:"red";s:19:"include_quick_terms";s:3:"yes";s:21:"include_property_type";s:2:"no";s:13:"include_price";s:3:"yes";s:18:"include_beds_baths";s:3:"yes";s:16:"include_keywords";s:3:"yes";s:34:"displet_quick_search_propertytypes";s:29:""House","Condo","Land","Farm"";s:29:"displet_quick_search_minprice";i:75;s:29:"displet_quick_search_maxprice";i:2000;s:35:"displet_quick_search_priceincrement";i:100;s:28:"displet_quick_search_maxbeds";i:6;s:29:"displet_quick_search_maxbaths";i:6;s:10:"map_height";s:0:"";s:9:"map_width";s:0:"";}', 'yes'),
    (56535, '_site_transient_update_plugins', 'O:8:"stdClass":3:{s:12:"last_checked";i:1359993371;s:7:"checked";a:32:{[...]s:48:"displetreader-wordpress-plugin/DispletReader.php";s:7:"1.5.0.4";[...]}s:8:"response";a:0:{}}', 'yes'),

    table=wp_posts:

    (723, 1, '2013-02-02 19:59:35', '2013-02-03 00:59:35', '[DispletFrame]', 'test', '', 'private', 'open', 'closed', '', 'test', '', '', '2013-02-02 19:59:35', '2013-02-03 00:59:35', '', 0, 'http://paulettewilliamsrealty.com/?page_id=723', 0, 'page', '', 0),
    (724, 1, '2013-02-02 19:59:04', '2013-02-03 00:59:04', ' [DispletFrame]', 'test', '', 'inherit', 'open', 'closed', '', '723-revision', '', '', '2013-02-02 19:59:04', '2013-02-03 00:59:04', '', 723, 'http://paulettewilliamsrealty.com/723-revision/', 0, 'revision', '', 0),

    Unless I'm mistaken, Displet leaves virtually everything in the DB.

    HTH

  11. NetAlien
    Member
    Posted 2 years ago #

    Getting weird... re-installed and now working. Removed IDX link & checked free...
    My hosting site in UT was unavailable late Saturday evening for a few hours. Maybe they are restoring some stuff...?
    Hate when I can't nail down the root cause... :(

    Only thing I can suggest is to verify/ignore old data on a [re-]install...

  12. displetdev
    Member
    Plugin Author

    Posted 2 years ago #

    Like I said, we can't replicate it on our end, so there's not much we can/should do.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic