• Resolved egocefalo

    (@egocefalo)


    Hi, first of all thanks for your plugin!

    On this last update (4.0) I got “the email” that wordpress found an error with one of my plugins, Post Snippets (free).

    With the following error details:

    E_ERROR en la línea 44 del archivo /home/****/****.com/wp-content/plugins/post-snippets/views/jquery_ui_dialog_footer.php. Mensaje de error: Uncaught Error: Call to undefined method PostSnippets\Shortcode::filterVars() in /home/****/****.com/wp-content/plugins/post-snippets/views/jquery_ui_dialog_footer.php:44
    Stack trace:
    #0 /home/****/****.com/wp-content/plugins/post-snippets/src/PostSnippets/View.php(21): include()
    #1 /home/****/****.com/wp-content/plugins/post-snippets/src/PostSnippets/WPEditor.php(241): PostSnippets\View::render('jquery_ui_dialo...', Array)
    #2 /home/****/****.com/wp-includes/class-wp-hook.php(308): PostSnippets\WPEditor->addJqueryUiDialog('update.php')
    #3 /home/****/****.com/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters(NULL, Array)
    #4 /home/****/****.com/wp-includes/plugin.php(517): WP_Hook->do_action(Array)
    #5 /home/****/****.com/wp-admin/includes/template.php(2157): do_action('admin_footer', 'update.php')
    #6 /home/****/****.com/wp-admin/update.php(53): iframe_footer()
    #7 {main}
      thrown

    I checked the website and used the plugin on a post and everything seems fine, no issues found, but the fatal error message still worries me.

    Should I roll back as you suggest?: (Thank you to updating Post Snippets v 4.0, we have recoded the entire plugin please check your all snippets if there is any issue you can download the previous version from here).

    Thanks for your help!
    Regards,

Viewing 15 replies - 1 through 15 (of 21 total)
  • Mohit Chawla

    (@m9729640633)

    Hi Developer
    please give priority to this one. complete website showing sql codes all over in admin with latest update.

    Andreas

    (@perryzelda)

    Same here.

    It seems, as if the plugins-authors themselves were not sure, if there are bugs. Why else is there a note in the backend after the update, where to roll back to the previous version (that’s something I have never seen before with any update of any plugin).

    My impressions is that they rolled out the plugin without serious testing. Not a good idea to use normal users as “beta-testers”

    hothbricks

    (@hothbricks)

    also : last update has an issue with Freemius behavior, it generates thousands calls to DB for nothing. Hosting company was not very pleased with that.

    jh20001

    (@jh20001)

    Same. I had to rollback as well as it was causing a huge error of code to display within the header everywhere within the admin section. Something about checking that it is in the footer, yatta yatta then a bunch of code. Rolled back and disabled the auto-update for it for now.

    jh20001

    (@jh20001)

    Update: here is the error we saw…

    “; jQuery(document).ready(function($){ // We do the check to see if post snippets dialog is in the footer. // Some plugins, like ‘download monitor’ uses WordPress admin bootstrap and // then bring in admin_head but not admin_footer. So to allow other plugins // to do that ‘hack’, we bail out in thoise cases. if ($(“#post-snippets-tabs”).length>0) { if($.isFunction($().tabs)){ // Ensure the tabs function is available var tabs = $(“#post-snippets-tabs”).tabs(); } $(function() { if($.isFunction($().dialog)){ // Ensure the dialog function is available $(“#post-snippets-dialog”).dialog({ autoOpen: false, modal: true, dialogClass: ‘wp-dialog’, buttons: { Cancel: function() { $(this).dialog(“close”); }, “Insert”: function() { $(this).dialog(“close”); var selected = tabs.tabs(‘option’, ‘active’); if (selected == 0) { insert_snippet = postsnippet_0; } if (selected == 1) { insert_snippet = postsnippet_1; } if (selected == 2) { insert_snippet = postsnippet_2; } if (selected == 3) { insert_snippet = postsnippet_3; } if (selected == 4) { insert_snippet = postsnippet_4; } if (selected == 5) { insert_snippet = postsnippet_5; } // Decide what method to use to insert the snippet depending // from what editor the window was opened from if (post_snippets_caller == ‘html’) { // HTML editor in WordPress 3.3 and greater QTags.insertContent(insert_snippet); } else { // Visual Editor post_snippets_canvas.execCommand(‘mceInsertContent’, false, insert_snippet); } } }, width: 500, }); } }); } }); // Global variables to keep track on the canvas instance and from what editor // that opened the Post Snippets popup. var post_snippets_canvas; var post_snippets_caller = ”;

    Plugin Support Mirza Hamza

    (@hamza1010)

    HI @jh20001 @egocefalo @m9729640633 @perryzelda,

    Thanks for contacting us,

    I hope you are doing well, We tested before release and after this support topic was published we again tested the plugin with multiple scenarios but we were unable to replicate the issues mentioned.

    Can you give us more information like a screencast video showing the issue, the way you have added snippets (page or post backend), and how it is being displayed on the front end?

    We will also need PHP and WP versions being used.

    It will help us replicate the issues on our staging site, once we are able to replicate the issue then we should be able to provide a fix.

    @hothbricks,

    We will update the freemium library to its latest release in the upcoming update.

    Thanks & Regards

    WP Experts Support Team

    Andreas

    (@perryzelda)

    WP Error-Message

    WP 6.1.1
    PHP 8.1

    Fehler-Details
    ==============
    Ein Fehler vom Typ E_ERROR wurde in der Zeile 44 der Datei /www/htdocs/…//wp-content/plugins/post-snippets/views/jquery_ui_dialog_footer.php verursacht. Fehlermeldung: Uncaught Error: Call to undefined method PostSnippets\Shortcode::filterVars() in /www/htdocs/…//wp-content/plugins/post-snippets/views/jquery_ui_dialog_footer.php:44
    Stack trace:
    #0 /www/htdocs/…//wp-content/plugins/post-snippets/src/PostSnippets/View.php(21): include()
    #1 /www/htdocs/…//wp-content/plugins/post-snippets/src/PostSnippets/WPEditor.php(241): PostSnippets\View::render(‘jquery_ui_dialo…’, Array)
    #2 /www/htdocs/…//wp-includes/class-wp-hook.php(308): PostSnippets\WPEditor->addJqueryUiDialog(‘update.php’)
    #3 /www/htdocs/…//wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters(NULL, Array)
    #4 /www/htdocs/…//wp-includes/plugin.php(517): WP_Hook->do_action(Array)
    #5 /www/htdocs/…//wp-admin/includes/template.php(2157): do_action(‘admin_footer’, ‘update.php’)
    #6 /www/htdocs/…//wp-admin/update.php(53): iframe_footer()
    #7 {main}
    thrown

    Regards
    Andreas

    Thread Starter egocefalo

    (@egocefalo)

    Hi @hamza1010

    As I explained on my first post the only evidence of the error was the one on the wordpress warning email. Everything worked as expected then and have been working as expected until now. No further warnings or visible errors.

    I’m using the latest WP version 6.1.1 on PHP 7.2

    Thank you!
    Best regards,

    jh20001

    (@jh20001)

    As for myself, the error I saw is in the header section of every admin section page. You can see it in the following screenshot:

    https://i.imgur.com/5FnUets.png

    As for where snippets are added, they are only added to a few posts here and there within the posts. Just some text within a table and such that gets repeated from time to time. Nothing to do with the backend. Plugin itself still functions when writing a post and everything. You just get all that text at the top on every page of the admin section.

    jh20001

    (@jh20001)

    An update: I take that back. Rolling back to the new version, it does not work properly either. Clicking on the post-it note icon in the strip does not result in any actions. So the old version has to be used. Sadly, we keep having to roll it back because WordPress won’t let us disable updates for it. We may have to switch to a different plug in for the time being.

    Plugin Support Mirza Hamza

    (@hamza1010)

    Hi @jh20001 @egocefalo @perryzelda,

    Kindly use the updated plugin.

    Here is the updated plugin: Post Snippets.

    Please update the plugin and let me know if you still have any issues.

    Thank you

    Thread Starter egocefalo

    (@egocefalo)

    Hi @hamza1010

    I just did and everything seems to be fine now. No error message or WP email warning. At least in my case it worked.

    Thanks for your help!
    Best regards,

    Yep, that seems to have worked for us too. Right on!

    Same here: installed it on one site. No issues through installation and no automatic error report from WordPress core.
    Thanks!

    Plugin Support Mirza Hamza

    (@hamza1010)

    Hi @perryzelda @jh20001 @egocefalo,

    We would appreciate a kind and honest review.

    Thank you

Viewing 15 replies - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.