Support » Fixing WordPress » Error on HP

  • Dear all,
    I have a website ( http://www.eagry.dk ) and it has worked perfectly fine until know.
    But this morning I saw a lot of error’s when I tried to enter the site. This is the error;

    Warning: Declaration of P_Photocrati_NextGen::define() should be compatible with C_Base_Product::define($id = ‘pope-produ…’, $name = ‘Pope Produ…’, $description = ”, $version = ”, $uri = ”, $author = ”, $author_uri = ”, $context = false) in/var/www/eagry.dk/public_html/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/product.photocrati_nextgen.php on line 0

    I have not installed a new plug-in or anything so I do not know why there is an error. Further I can not even enter the wp-admin site.

    I REALLY DO NOT know what to do from here so I need some help. Anyone ?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The error is coming from the NextGen plugin.

    Do you know how to use ftp so that you can deactivate the plugin manually? I usually do that by renaming it with a period . in front of the plugin name. If you don’t know how to use ftp, you could use the file manager in your hosting account or contact your host for assistance.

    Once the plugin is deactivated, you should be able to access the site and then troubleshoot from there.

    I am SO glad to hear that there is a solution for this, kwbridge! Thank you.

    I can use an ftp yes – but I do not know how to deactivate the plugin. Do you have a quick and easy to understand guide ? Or is it easier to guide via the file manager ?

    So glad that you are able to help:-)

    If you login via ftp you will want to go to the wp-content folder

    /wp-content/plugins – there you will see all of your plugins.
    In the list you should see nextgen-gallery
    Right click on the name of that folder, select rename and then rename it with a period in front like .nextgen-gallery – that will make it unavailable to WordPress.

    After doing that see if you are able to access your site. It is possible there will be other errors but we want to get past this one first.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Error on HP’ is closed to new replies.