• Resolved tzeldin88

    (@tzeldin88)


    Unable to generate a Key on destination site.
    When I click Generate, it immediately shows a browser-alert ERROR:

    wpvivid_request: error(): an error occurred when trying to establish communication with your server. This error may be request not reaching or server not responding. Please try again later.

    This is a fresh wp install, v5.6.1, with default 2021 theme and NO other plugins enabled.

    • This topic was modified 3 months, 1 week ago by tzeldin88.
Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support tonyrobins

    (@tonyrobins)

    Hi @tzeldin88

    First, please make sure that it’s not a problem with the website itself, you can do that by trying to use other WPvivid functions, for example, creating a backup.

    If you get the same error with all functions, you can use the browser’s developer tool to check the specific error message, and then fix the error.

    All the best,

    Thread Starter tzeldin88

    (@tzeldin88)

    @tonyrobins Thanks for such a fast reply!

    Great idea, to test other functions. But the backup worked, no errors.

    In wp > tools > site health, the only issue is outdated PHP (7.1), and this is literally why I’m trying to setup a staging site.. to safely test the site on php 7.4. No alerts for REST api, https, loopbacks, background updates.. those are all “passed tests”.

    HostGator did have a MU Plugin (Endurance Cache), but I disabled it (moved the file out of plugins/ dir.).

    I see lots of positive reviews on WPVivid, and I was excited to try it. I wonder why it’s not working here.

    Thread Starter tzeldin88

    (@tzeldin88)

    Also, I (successfully) used the plugin’s Debug tab to send debug info to you.

    Thread Starter tzeldin88

    (@tzeldin88)

    I also got errors when uploading a backup-zip from my Production site (generated by WPVivid).

    Error 1 (browser alert)

    .. error code: -200, HTTP Error

    closing that alert then opens
    Error 2 (browser alert)

    Upload file failed. .. error: PCLZIP_ERR_MISSING_FILE (-4) : Missing archive file ..

    So I uploaded the zip via SFTP, to the wpvividbackups dir, but the plugin does not see it.

    And, I got the same/original error another way — clicking the “Scan uploaded backup or received backup” button, for the backup of the Destination site I had done earlier at your suggestion.

    wpvivid_request: error(): an error occurred when trying to establish communication with your server. This error may be request not reaching or server not responding. Please try again later.

    Plugin Support tonyrobins

    (@tonyrobins)

    Thanks @tzeldin88

    We are going to check out the debug zip soon and will let you know updates.

    All the best,

    Hey,
    Have you solved that issue?
    I am facing the same thing today.

    Thread Starter tzeldin88

    (@tzeldin88)

    I had this problem on 3 sites, all on HostGator, and never got this plugin working there. I ended up cloning my sites another way. I copied the files in the hosting file manager (updating wp-config accordingly), and use the WP Migrate DB plugin for the database.

    Thread Starter tzeldin88

    (@tzeldin88)

    I thought I’d try this plugin again, on a different site, this time on DreamHost. Got same ERROR. Also tried just running a database backup to local.. stalled and failed. This is not a big site. This plugin has failed 4/4 times I’ve tried it.

    Plugin Support tonyrobins

    (@tonyrobins)

    Hi @tzeldin88

    Sorry I almost missed your update.

    After more than 50 versions of version iterations in the past two years, the plugin has been proven to be very stable now. And From the feedback we have gathered so far, we see that most issues experienced with the current version of our plugin are typically related to limits with web hosts or site configurations.

    So, you can try the following WPvivid Settings to increase the backup success rate,

    In General Settings

    1. Uncheck the option of ‘Merge all the backup files into single package when a backup completes’

    In Advanced Settings

    2. Check the option of ‘Enable optimization mode for web hosting/shared hosting’
    3. Compress files every 100 MB
    4. PHP script execution timeout for backup 900 seconds
    6. PHP memory for backup 512 MB
    7. Retrying times when encountering a time-out error: 9 times

    Save changes and run a backup again.

    I am going to close this thread, feel free to create a new thread if you have any issues using our plugin in the future.

    All the best,

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.