Support » Plugin: Sell Media » Error on fresh installation

  • I just setup a fresh installation of WordPress and Sell Media is one of the first plugins I installed for this project. I’ve tested this against a brand new installation with it being the only plugin active along with the default 2017 WP theme.

    This is showing in the source code:

    [18-Jan-2017 14:59:46 UTC] PHP Warning:  session_start(): Failed to read session data: user (path: /srv/users/serverpilot/tmp/print-splash) in /srv/users/serverpilot/apps/print-splash/public/wp-content/plugins/sell-media/inc/class-cart.php on line 30
    
    

    And these are other warnings showing up in the debug log:

    [18-Jan-2017 14:59:45 UTC] PHP Warning:  Cannot modify header information - headers already sent by (output started at /srv/users/serverpilot/apps/print-splash/public/wp-content/plugins/sell-media/inc/class-cart.php:30) in /srv/users/serverpilot/apps/print-splash/public/wp-includes/pluggable.php on line 893
    
    [18-Jan-2017 14:59:45 UTC] PHP Warning:  Cannot modify header information - headers already sent by (output started at /srv/users/serverpilot/apps/print-splash/public/wp-content/plugins/sell-media/inc/class-cart.php:30) in /srv/users/serverpilot/apps/print-splash/public/wp-includes/pluggable.php on line 894
    
    [18-Jan-2017 14:59:45 UTC] PHP Warning:  Cannot modify header information - headers already sent by (output started at /srv/users/serverpilot/apps/print-splash/public/wp-content/plugins/sell-media/inc/class-cart.php:30) in /srv/users/serverpilot/apps/print-splash/public/wp-includes/pluggable.php on line 895

    About the only thing unique here is that I’ve already installed the SSL cert for the domain, which should not be an issue.

    I’ve been wanting to use this plugin for a while know and have followed it’s development. Any chance you can look into this and get it sorted and push out an update?

Viewing 2 replies - 1 through 2 (of 2 total)
  • So, after some further testing, I can say that Sell Media is not compatible with PHP 7.1. I downgraded my PHP version to 7.0 and the error in the source code went away, and I can confirm that the other PHP warnings were no longer logging into the debug log.

    So, overall not a huge issue then at this point. 7.1 is pretty bleeding-edge so it isn’t a problem yet really. Probably something worth noting and taking a look at in the not to distant future!

    Thanks.

    Plugin Author Thad Allender

    (@endortrails)

    Feel free to post any specific issues related to PHP 7.1 to GitHub:

    https://github.com/graphpaperpress/Sell-Media/

    We are using PHP 7.0 and there are no warnings. I’d be curious to know if the warning is something specific to PHP or Sell Media.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Error on fresh installation’ is closed to new replies.