Support » Plugin: bbPress Genesis Extend » Error on forum pages

  • Resolved Andrea Whitmer

    (@nutsandboltsmedia)


    I just installed the plugin and I’m seeing the following error on all forum pages:

    Warning: in_array() expects parameter 2 to be array, null given in /home/USER/public_html/DOMAIN.com/wp-content/themes/genesis/lib/functions/general.php on line 293

    Looking at the file in question, this appears to be related to custom post types:

    function genesis_has_post_type_archive_support( $post_type_name = '' ) {
    
    	$post_type_name = genesis_get_global_post_type_name( $post_type_name );
    
    	return in_array( $post_type_name, genesis_get_cpt_archive_types_names() ) &&
    		post_type_supports( $post_type_name, 'genesis-cpt-archives-settings' );
    
    }

    Is this a Genesis 2.0 issue, or do I need to look for another cause? I saw another topic that mentioned some changes needed for HTML5 sites, so if that’s the case, I’ll be patient and wait for a plugin update.

    Also, the Genesis author box and “Filed Under” are still showing on forum pages, so I’m wondering what I need to do about that.

    http://wordpress.org/plugins/bbpress-genesis-extend/

Viewing 15 replies - 1 through 15 (of 22 total)
  • I am experiencing the exact same problem. This is a Genesis 2.0 – bbpress error, as I have no other plugins installed.

    I have something to add. The error/warning only shows when you are logged out of wordpress.

    Does anyone know how to solve this issue?

    Andrea Whitmer

    (@nutsandboltsmedia)

    Yes, that’s true in my case as well re: being logged out. I didn’t see it until I did a test registration and was logged in as a user instead of an admin.

    I can’t find a solution to this anywhere even though anyone running bbpress on the genesis 2.0 framework must be having this problem.

    I will ask around and see if anyone can come up with a quick fix..

    I experienced this error when I used a “link type” menu item pointing to /forums/.

    I do not have HTML5 activated, because bbPress Genesis Extend does not support it yet.

    Workaround:
    Insert this shortcode [bbp-forum-index] on a page and include the page in the menu.

    Andrea Whitmer

    (@nutsandboltsmedia)

    Actually that’s how my page is configured – using the shortcode. And it’s not even listed on my menu. Yet I still see the error.

    Plugin Author Jared Atchison

    (@jaredatch)

    This is an issue with Genesis 2.0 (not this plugin) and is something I will need to try to fix with the plugin, among all the new hook updates for G2.

    This plugin does NOT support Genesis 2 yet. Upgrading to Genesis 2 is not recommended if you use bbPress.

    Support for Genesis 2 is planned and will be added in a future update.

    Plugin Author Jared Atchison

    (@jaredatch)

    Specifically, what child theme are you using?

    I have tried 3 different XHTML child themes with Genesis 2.0.0 and have not encountered that error.

    Are you trying to use HTML5 child themes?

    I’m using the Focus theme.

    The same warning displays 6 times above the header and 1 time below, which means that the whole forum is below the viewable area on the screen. I’m afraid this will hurt my rankings on google if this isn’t fixed soon..

    Andrea Whitmer

    (@nutsandboltsmedia)

    I’m using the Jade child theme from Restored 316, which I believe has already been updated for HTML5. My situation isn’t urgent since the site is still in development, but when I started the thread I wasn’t sure if it was an HTML5 issue or not.

    I’m using the childtheme Dynamik Website Builder 1.2.2 from cobaltapps.com.

    It is HTML5/CSS3 theme, but it can be disabeled, which it is in my case.

    See this post:

    Plugin Author Jared Atchison

    (@jaredatch)

    The error:

    Warning: in_array() expects parameter 2 to be array, null given in /home/USER/public_html/DOMAIN.com/wp-content/themes/genesis/lib/functions/general.php on line 293

    is an issue with Genesis core. A bug report has been filed and a patch is in the works, so I suspect that issue will be addressed in an update such as 2.0.1.

    Adding support for HTML5 in this plugin should be done by the end of the month.

    That sounds excellent!
    Thank you for your help, it is much appreciated.

    For those who want a fix now, and understand the implications of hacking Genesis core (seriously – do you understand?), then add:

    $post_type_names = array();

    on line 269 of genesis/lib/functions/general.php, right before the line with the foreach(), inside the genesis_get_cpt_archive_types_names() function.

    Andrea Whitmer

    (@nutsandboltsmedia)

    Thank you, Gary. Now I can finally get this site launched – that worked beautifully!

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Error on forum pages’ is closed to new replies.