Support » Plugin: bpost shipping » Error on cart and checkout pages

  • Resolved josselynj

    (@josselynj)


    Hi
    If i activate the debug mode and show the error i can see errors from your plugin and here is the error display on the cart and checkout pages :

    Warning: Use of undefined constant CURLOPT_SSL_VERIFYSTATUS – assumed ‘CURLOPT_SSL_VERIFYSTATUS’ (this will throw an Error in a future version of PHP) in /home/xxxxx/www/wp-content/plugins/bpost-shipping/vendor/antidot-be/bpost-api-library/src/Bpost.php on line 235

    Warning: curl_setopt_array(): supplied argument is not a valid File-Handle resource in /home/xxxxx/www/wp-content/plugins/bpost-shipping/vendor/antidot-be/bpost-api-library/src/ApiCaller/ApiCaller.php on line 84

    Are u aware of that, and can you fix the problem πŸ™‚ ?
    Thank you

Viewing 10 replies - 16 through 25 (of 25 total)
  • I have that same error.
    FastCGI sent in stderr: “PHP message: PHP Warning: curl_setopt_array(): supplied argument is not a valid File-Handle resource in /www/xxxx/public/wp-content/plugins/bpost-shipping/vendor/antidot-be/bpost-api-library/src/ApiCaller/ApiCaller.php on line 82” while reading response header from upstream.

    It’s even that bad, that I had to deactivate the plugin (before this update, I’ll see what if it still kills my website).

    Plugin Author Antidot developer

    (@antidot-dev)

    @topanga can you tell me which version of PHP/curl are you using?

    I will re-deploy a release in few minutes (by removing some SSL options in curl requests)

    PHP 7.3

    curl –version
    curl 7.68.0 (x86_64-pc-linux-gnu) libcurl/7.68.0 OpenSSL/1.1.1i zlib/1.2.11 brotli/1.0.7 libidn2/2.3.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

    Plugin Author Antidot developer

    (@antidot-dev)

    With the version 2.3.16, the issue is again present?

    I have just upgraded and will let you know once I have running my shop for a couple of hours. I have done one test and I do not see an error (yet).
    Let’s hold some wood and cross some fingers.

    Did u upgrade a new version for the plugin?
    I try to upgrade?

    @nabilbd, I have now upgraded to 2.3.16. I need to have it run for a couple of hours (to have at least a couple of people buying something that they need to have shipped)
    The 2.3.15 version was NOT solving my errors.

    Plugin Author Antidot developer

    (@antidot-dev)

    Let me know if the 2.3.16 solves it πŸ™‚ .

    Already two hours without any warnings or errors. That is a record πŸ™‚

    Yrs i updated too, all the errors disappeared. Now waiting also for orders to be made.

Viewing 10 replies - 16 through 25 (of 25 total)
  • The topic ‘Error on cart and checkout pages’ is closed to new replies.