WordPress.org

Support

Support » Plugins and Hacks » Duplicator » [Resolved] error on backing up

[Resolved] error on backing up

  • Just tried to back up and received the following error:

    AJAX Response form-duplicator submit
    duration: 1358273647.281 secs
    code: 200
    status: OK
    response:
    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 45 bytes) in /home/content/06/9955606/html/oursite/wp-includes/meta.php on line 571

    I backed up several times with duplicator in the last month and never saw this before. Tried it several times and always received the same error. We are using godaddy for this site.

    http://wordpress.org/extend/plugins/duplicator/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Cory Lamle

    @corylamleorg

    Hey carlytx,

    Here is a helpful section on the FAQs page:
    -> Browse To: http://lifeinthegrid.com/duplicator-faq/
    -> Find Section: “3. Troubleshoot”
    -> See Area/Question: “Fatal error: Allowed memory exhausted” and the memory setting is maxed out?”

    Hope that helps!

    thanks, tried it already and it didn’t help and I don’t expect any help from godaddy since they don’t do much to support third party software.

    what I don’t understand is why it stopped working. As I indicated I backed up several times in the last month without an error.

    Plugin Author Cory Lamle

    @corylamleorg

    Yeah I see what your saying… The problem is that you might run into it on another plugin or somewhere else in the future. The error is actually coming from an internal core WP file (meta.php).

    Does GD have a way to increase your memory on their servers? This seems to be a relevant problem with other plugins running on hosts with stingy memory settings…

    I Googled “Allowed memory size meta.php 571” and found some other threads talking about the same issue…

    This plugin does require some of your systems memory (but nothing unreasonable for a process of this sort) as its making use of ZipArchive which will require some overhead. My feeling is that GD caps you at 32MB which is pretty low for a process that requires some heavy lifting…

    This GD help article might help:
    http://support.godaddy.com/groups/web-hosting/forum/topic/fatal-error-allowed-memory-size-exhausted/

    Thanks for the link. I tried their suggestion of raising the memory setting in the php.ini file to 128mb but unfortunately it didn’t work.

    I will try to call godaddy for some help but I don’t expect too much from them based on past experience.

    It is very unfortunate if we can’t use this plugin because it is a great piece of software and I am hoping we can still resolve this.

    Plugin Author Cory Lamle

    @corylamleorg

    You could always try something higher like 1000mb just to double check. Although they might have a cap. I have moved sites close to 2GB on several different hosts without any memory issues…

    Wish I could help more, however there isn’t to many options I really have as I’m limited to the libraries that I’m using via PHP. Hopefully in future versions I’ll have some other archive solutions…

    I tried to raise the limit to 1000mb as you suggested with no luck.

    I spoke with Godaddy’s first line support group and as expected they are totally useless.

    I just emailed their advanced support group and hope they can address this.

    We would really like to use your plugin.

    Good news. We just got it working again. Had to change both the php.ini file and the wp-config.php file.

    we noticed that the error indicated memory exhausted at just under 68mb
    so we set both entries to 80mb and it worked. I don’t know if both changes are needed but when we just changed the php.ini file it didn’t work.

    added in php.ini
    memory_limit = 80MB

    added in wp-config.php
    define(‘WP_MEMORY_LIMIT’, ’80M’);

    hope this helps someone else. just wasted a whole day 🙂

    Plugin Author Cory Lamle

    @corylamleorg

    Hey carlytx,

    Usually when the php.ini file is changed it won’t take affect until the Apache service is recycled. Its actually different across many of the hosts. Although it looks like the WP_MEMORY_LIMIT probably helped do the trick. I’ll try and get that one posted on the sites FAQ.

    Thanks for posting your solution!

    Thanks again for this plugin. Just did a restore this morning to test it and it works flawlessly.

    Plugin Author Cory Lamle

    @corylamleorg

    Awesome! Glad you back in business 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] error on backing up’ is closed to new replies.
Skip to toolbar