Support » Plugin: WordPress Social Share, Social Login and Social Comments Plugin - Super Socializer » Error on activating “super_socializer.php on line 338” Problem NOT solved

  • I get the “Parse error: syntax error, unexpected T_STRING in <…>/wp-content/plugins/super-socializer/super_socializer.php on line 338

    I am using PHP Version 5.2.17.
    I know, but this is my hosting and there is no way I’ll change hosting. All other plugins work like a charm.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor Heateor Support

    (@heateor)

    Sorry to hear that. But you need at least version 5.4 of PHP to get the plugin working. It should not be a difficult thing to upgrade PHP version to 5.4 in your hosting panel when we are already living in the era of PHP 7.

    It is impossible.
    At least for godaddy.com hosting service.
    So there is no way I could use your plugin.
    No problem, I see out there that other software developers have no difficulties in keeping their php plugins compatible.

    In my opinion having respect for compatibility is ultimately having respect for natural resources. You may fill in the gaps for yourself.

    Have a nice day.

    I’m just a user but want anyone reading this to realize WordPress doesn’t recommend you use PHP that is past the end of life. Check out https://wordpress.org/about/requirements/ for reasons why.

    Also, it looks like GoDaddy does have PHP 5.6 according to https://www.godaddy.com/help/software-versions-shared-hosting-897 so talk to GoDaddy or your host about upgrading if you haven’t.

    Lastly, support for PHP 5.2 ended over 7 years ago (http://php.net/eol.php) and this plugin’s first version was only 4 years ago so please don’t fault a developer for offering a free plugin to the community and then not having compatibility with something that was outdated when work began on the plugin.

    You are wrong in at least one assumption.
    Godaddy does have new php only on cPanel servers. On the other, they do not.
    And no, they are not upgrading.
    And no, this is not an excuse for bad coding.
    But again, this is just me.
    Have a nice day, sir !
    PS: Learn to code, excuses are for stupid.
    Just learn to code.
    And behave.

    My reply was meant as a note to others as GoDaddy has always upgraded PHP for me when I’ve asked it order to protect my clients. I’m sorry your situation is different but it was not my experience so I was sharing that for others.

    Again, this is not my plugin, but I do know how to code and could make this compatible, but would never do that because there have not been security updates for PHP 5.2 for 7 years. It’s open source so perhaps you can take your own advice and learn to code and adjust it to your needs instead of bashing the developer.

    Lol I already fixed that. However is quite annoying to see developers coding that way.

    And patching the plugin every upgrade down the road would be quite ridiculous.
    I am using 200+ plugins on my wordpress installs and this is the only one written that way.

    But again, it is just me.
    And is not bashing.
    Is coding the right side of the Force.
    Again, this is just me and I clearly see now it is not you.
    Have a nice day Sir !

    Moderator Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    Just learn to code.
    And behave.

    Please leave out personal remarks. Review the plugin, do not review the plugin author.

    • This reply was modified 9 months, 1 week ago by  Andrew Nevins.
Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Error on activating “super_socializer.php on line 338” Problem NOT solved’ is closed to new replies.