Support » Plugin: Watu Quiz » Error Occured message after submit

  • Resolved Pau Navarro

    (@pau4ner)


    Hi, I have been using Watu for several quizzes in my webpage. Everything was working fine but since last week all of them are showing an “Error occured” message instead the grade description after the users complete the quiz and clic on submit.

    Note: I changed nothing on my webpage. No new plugins or themes. I use WP Rocket for cache, but I am not using AutoOptimize or similar plugins.

    Here is one of the pages with the quizz: https://habilidadsocial.com/test-de-inteligencia-emocional

    Any help would be much appreciated, I was really happy with this plugin.

    Regards

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author prasunsen

    (@prasunsen)

    You need to switch off Ajax from the Watu Settings page.

    Thread Starter Pau Navarro

    (@pau4ner)

    Thanks for your help @prasunsen, I already did and cleared cache but that doesn’t seem to solve the problem. I still get the “Error occured” message. Any other suggestion?

    Thanks in advance and best regards

    Plugin Author prasunsen

    (@prasunsen)

    It’s not done, still submits by ajax. Please double check. If you use cache plugins, clear cache.

    Plugin Author prasunsen

    (@prasunsen)

    I can see that it’s still not set to use no ajax:

    <input type="hidden" name="no_ajax" value="0"

    And I see the possible reason in your source:

    website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1536631297 -->

    So WP Rocket is caching the page. Don’t chache dynamic pages with quizzes and similar at all. Any randomizations will also not work when the page is cached.

    Thread Starter Pau Navarro

    (@pau4ner)

    Thanks @prasunsen, I have added the URLs with the quizzes to WPRocket excluded URLs. I will check and let you know.

    Thread Starter Pau Navarro

    (@pau4ner)

    Hi @prasunsen, sorry to bother you. As excluding the URLs with the quizzes to WPRocket didn’t work, I deactivated WPRocket. To my surprise, the problem is still happening so I guess it is not WP Rocket related. Any other idea? I will try deactivating each plugin.

    Plugin Author prasunsen

    (@prasunsen)

    I can see in your page source that no_ajax is still 0. So it’s either cached or you have not really changed the setting. Maybe you forgot to hit save, I have no idea. But I can clearly see that the setting is not applied in the front-end. It works perfectly, I just double checked it.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Error Occured message after submit’ is closed to new replies.