Support » Plugin: Growmap Anti Spambot Plugin » Error notices in version 1.4.1 with debug turned on

  • Resolved Chad Bush

    (@ravenseye)


    I generally always develop with debugging options enabled, and it’s very noticeable when plugins have little errors that cause WP to spit out notices. Here are a couple of suggested fixes for the next update…

    These errors are from version 1.4.1 of the plugin:

    Line 220, '$ab_gasp' should be 'ab_gasp' — looks like a typo on your localization key. This throws an Undefined Variable notice.

    Line 243, wrap if(isset($options['trackbacks'])){ ... } around checked($options['trackbacks'],'yes'); to prevent an Undefined Index notice. I noticed this one on the last version of this plugin too.

    To the author, thanks again for all your hard work trying to keep one step ahead of those spammers!

    http://wordpress.org/plugins/growmap-anti-spambot-plugin/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Andy Bailey

    (@commentluv)

    thanks for the feedback Chad, funny but I fixed those things on my machine but uploaded the previous version that didn’t have the edits!

    doh!

    I’ll fix it in a future update

    Plugin Author Andy Bailey

    (@commentluv)

    btw.. are comments going though ok?

    it works on all my sites but someone is saying it is telling everyone that they are a spammer but I am assuming that they forgot to clear their cache.. just though I’d check with you..

    On my test sites I’m able to leave comments just fine by checking the box. Thanks for checking!

    Plugin Author Andy Bailey

    (@commentluv)

    Great! Thanks chad

    Plugin Author Andy Bailey

    (@commentluv)

    version 1.5.2 is now released

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Error notices in version 1.4.1 with debug turned on’ is closed to new replies.