Support » Plugin: shipcloud for WooCommerce » Error note // Please provide properties for the advanced_notice service

  • Resolved silbersalz35

    (@silbersalz35)


    Hi There,

    After updating the plugin, the option to use Additional services has been added, which is in it self fine. The problem is, that the checkmark on there is preselected and if we select a carrier which does not support any additional services – such as UPS – an error note gets triggered, wich prevents label creation: “Please provide properties for the advanced_notice service”

    This can be worked around if we deselect the checkbox before choosing such a carrier. But to do this every day for every order is very annoying/ time consuming. Is there a way how you can rethink how this is implemented?

    E.g. you already display this note that tells “The contract used for your currently selected carrier does not support additional services.” Cant you in the same way then deselect the checkbox, so that the error wont be displayed?

    Thanks & Greetings
    Chris

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author André Cedik

    (@andrecedik)

    Hi Chris,

    thank you for your feedback. This should definitely not happen. The process to determine what the user has selected is “a little” complicated and independent to what you get when loading the page, which is what you see when selecting a carrier who doesn’t support additional services.

    I’ll have a look at it right away.

    Plugin Author André Cedik

    (@andrecedik)

    Hi @silbersalz35
    I’ve just released a new version which should not transmit advance_notice when the carrier doesn’t support it. Please let me know if this fixes your problem.

    Thread Starter silbersalz35

    (@silbersalz35)

    Hi André,

    the problem seems to be fixed – thanks for that!

    Greetings
    Chris

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Error note // Please provide properties for the advanced_notice service’ is closed to new replies.