Support » Plugin: One Click Demo Import » Error Not Found (404)

  • Resolved joand

    (@joand)


    Hi @capuderg – I hope you are well. OCDI is working very well lately, I must tell you. I am able to package theme without ripping my hair out!
    However, I do have a problem with a guy trying to install one of my themes. After clicking the Import Demo Data link, it takes a while and then “Error Not Found (404)” comes up. The first time, no posts and pages were imported. In looking at the log file, it had successfully downloaded the xml and dat files. I noticed that it had “Initial max execution time – 30” at the top, where my test site, where the install works no problem has 150, so I thought maybe it was timing out and I got him to increase to 150. This time it did import the pages and posts, but didn’t do he after demo import stuff – and at the bottom of the log file it has

    New AJAX call!

    where mine (that worked successfully) has:

    —Importing customizer settings—
    Customizer settings import finished!

    —pt-ocdi/after_import—

    Do you think it is sill related to the max execution time – or do you have any other ideas?

    Thanks,
    Joan

Viewing 3 replies - 1 through 3 (of 3 total)
  • capuderg

    (@capuderg)

    Hi Joan,

    I’m glad OCDI is helping you out 🙂

    The max execution time should not be an issue, since the AJAX calls are set to be 25 seconds long.

    Did you try to import the content manually for him with the old/default WP importer? I’m not sure, what a 404 error would mean in this case, so I don’t have any concrete suggestions.

    Take care!

    joand

    (@joand)

    Always something new! Yes it would be helpful if we could know what was not found!

    I did not try to import the content manually – I wanted to try and get it working for him as he wants to use on other sites. We did try the OCDI import 3 times. The first time he did it and it imported 4 pages (out of 10 pages and 6 posts). The next time (after reinstalling WordPress) I tried and it imported no pages or posts. After we changed the execution time (maybe just coincidence) it imported all the pages and posts, but stopped there. In all cases it showed the xml and dat files as having been imported in the log file – but it did not get so far as the dat file.

    I did end up importing the theme settings manually and setting the home page and menu, so it is “solved” for now. I had a look at his php settings and I didn’t see anything else that jumped out other than the execution time. The hosting company is DreamHost, which is known as a good hosting company for WordPress (and even recommended by WP itself) so I would not have expected to run into a problem there.

    capuderg

    (@capuderg)

    Hmm…

    Did you maybe check the PHP logs on the server? If there are any errors, that could point us in the right direction? But since it was a 404 error and not a 5xx error (server side errors), I don’t think it would show in PHP logs 🙁

    I’m sorry I wasn’t of more help to you for this issue.

    Take care!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Error Not Found (404)’ is closed to new replies.