Support » Plugin: Stripe Payments WordPress Plugin – WP Simple Pay » Error: Not a valid URL

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author spencerfinnell

    (@spencerfinnell)

    Hello @voodoochill,

    Is your website currently using any other Stripe-related plugins? This error often occurs when another plugin is using the same Stripe PHP library WP Simple Pay uses, but are using an older version.

    WP Simple Pay uses the latest version of the Stripe PHP library and the latest version of the Stripe API.

    Thread Starter voodoochill

    (@voodoochill)

    Hi Spencer, thanks for speedy response.

    I am also using Woocommerce Stripe gateway but I get the issue even if I deactivate that.

    Plugin Author spencerfinnell

    (@spencerfinnell)

    Thank you for the information @voodoochill,

    Are you able to post the contents of Simple Pay Lite > System Report? Please redact your “Home URL” and “Site URL” if you do not want them visible.

    Also, in your Stripe Dashboard, do you see any requests similar to POST /v1/checkout/sessions when you visit: https://dashboard.stripe.com/test/logs?method%5B%5D=post&method%5B%5D=delete&direction%5B%5D=connect_in&direction%5B%5D=self

    Thread Starter voodoochill

    (@voodoochill)

    
    ### WordPress Installation ###
    
    Site Name: Taming The Saxophone
    
    SSL/HTTPS Enabled: Yes
    Version: 5.4.1
    Locale: en_US
    Multisite: No
    Permalinks: /%postname%
    WP Memory Limit: 256 MB
    WP Debug Mode: No
    Script Debug: No
    
    ### WP Simple Pay Lite Settings ###
    
    WP Simple Pay Lite Lite Version: 2.3.3
    Stripe TLS: Cannot test TLS 1.2 support until your Stripe Test Secret Key is entered.
    Simple Pay Test or Live Mode: Live Mode
    
    ### Active Theme ###
    
    Theme: Ample Child -
    Child Theme: Yes
    Parent Theme: Ample - 1.2.7
    
    ### Active Plugins ###
    
    Widget Shortcode: 0.3.4
    Search by ID: 1.3
    Yoast SEO: 14.0.4
    Wonder Slider Pro: 12.4C
    Wonder Popup Pro: 6.3C
    Relevanssi: 4.7.2.1
    Max Mega Menu: 2.7.7
    Max Mega Menu - Pro Addon: 2.0.1
    Currency Converter Widget: 2.0.5
    Product Open Pricing (Name Your Price) for WooCommerce Pro: 1.4.4
    WP Simple Pay Lite: 2.3.3
    WP Mail SMTP: 2.0.0
    Advanced Ads: 1.17.11
    WooCommerce Stripe Gateway: 4.3.3
    Post Type Switcher: 3.2.0
    Heartbeat Control by WP Rocket: 2.0
    Health Check & Troubleshooting: 1.4.4
    Classic Editor: 1.5
    Broken Link Checker: 1.11.12
    BBSpoiler: 2.01
    WooCommerce: 3.9.3
    Mailchimp for WooCommerce: 2.4.0
    List category posts: 0.81
    404 to 301 - Redirect, Log and Notify 404 Errors: 3.0.5
    Contact Form 7: 5.1.7
    Better Search Replace: 1.3.3
    Akismet Anti-Spam: 4.1.5
    Wordfence Security: 7.4.7
    Wonder Gallery Pro: 13.0C
    Wonder Audio Player Pro: 9.5C
    Plugins Garbage Collector: 0.10.4
    Coming Soon Page, Under Construction & Maintenance Mode by SeedProd: 5.1.0
    WooCommerce Dynamic Pricing & Discounts: 2.3.8
    Cookie Notice: 1.3.1
    Easy Social Icons: 3.0.7
    mb.miniAudioPlayer: 1.9.3
    SOGO Add Script Header Footer: 3.9
    Social Media Feather: 1.9.4
    Contact Form 7 Extension For Mailchimp: 0.5.17
    RSS Includes Pages Pro: 3.8.1
    Dynamic Widgets: 1.5.16
    Easy Table of Contents: 2.0.11
    Contact Form 7 Conditional Fields: 1.8.6
    Simple Revisions Delete by bweb: 1.5
    
    ### Server Environment ###
    
    Web Server: LiteSpeed
    PHP Version: 7.3.17
    MySQL Version: 5.5.5-10.3.22-MariaDB
    Server Timezone: UTC
    Display Errors: No
    Server PHP Memory Limit: 512M
    Upload Max Filesize: 20M
    Post Max Size: 20M
    Max Execution Time: 300
    Max Input Vars: 10000
    cURL Enabled: Yes
    cURL Version: 7.69.1
    OpenSSL/1.1.1g
    mbstring (Multibyte String) Enabled: Yes
    fsockopen: Yes
    SOAP: No
    SUHOSIN: No
    WP Remote POST: Yes
    WP Remote GET: Yes
    
    ### Client Information ###
    
    Browser: Firefox 75.0 (Apple)
    

    In Stripe I see this:

    200 OK
    	
    DELETE /v1/webhook_endpoints/xxxxxxxxxxx
    	
    05/01/2019, 18:42:14
    200 OK
    	
    POST /v1/tokens
    	
    05/01/2019, 18:40:58
    200 OK
    	
    POST /v1/tokens
    	
    05/01/2019, 18:37:39
    200 OK
    	
    POST /v1/webhook_endpoints/xxxxxxx
    	
    05/01/2019, 18:36:52
    200 OK
    	
    POST /v1/webhook_endpoints
    	
    05/01/2019, 18:36:43
    200 OK
    	
    POST /v1/tokens
    	
    05/01/2019, 18:31:15
    200 OK
    	
    POST /v1/charges
    	
    26/10/2018, 18:55:06
    200 OK
    	
    POST /v1/customers
    	
    26/10/2018, 18:55:05
    200 OK
    	
    POST /v1/tokens
    	
    26/10/2018, 18:55:01
    9 results
    
    Plugin Author spencerfinnell

    (@spencerfinnell)

    Thank you @voodoochill. Is that Stripe account the same one you are using WooCommerce with? I would expect to see more logs from this year.

    Do you have Webhooks configured in https://dashboard.stripe.com/webhooks for WooCommerce? Can you verify those URLs are valid?

    Thread Starter voodoochill

    (@voodoochill)

    No it’s a different stripe account.

    In the stripe account I have for Woocommerce I have webhook: https://tamingthesaxophone.com/?wc-api=wc_stripe

    I’m not sure how to verify it’s valid, but it’s what I pasted in from the Stripe settings in Woocommerce

    Plugin Author spencerfinnell

    (@spencerfinnell)

    @voodoochill Are you able to try connecting WP Simple Pay to the same Stripe account that you are processing WooCommerce payments with temporarily? Does that allow Stripe Checkout to function?

    Thread Starter voodoochill

    (@voodoochill)

    Done that, same thing happens

    Plugin Author spencerfinnell

    (@spencerfinnell)

    Thank you for testing @voodoochill. Can you please verify the settings in “Simple Pay Lite > Settings > General” for “Payment Success Page”, “Payment Failure Page”, and “Payment Cancelled Page” point to valid pages? Please resave those settings once verified.

    I was able to reproduce your error by assigning a page to “Payment Success Page” then deleting that page in WordPress. Ensuring each setting has a valid value should solve your issue.

    Thread Starter voodoochill

    (@voodoochill)

    Yes they point to pages, but they are random pages of my site nothing to do with payments.

    But there are only “Payment Success Page”, “Payment Failure Page”,

    Not “Payment Failure Page”

    I should point out the plugin was installed then uninstalled then reinstalled . Are those special pages that are created on installing? But not on reinstalling? Could that be the issue?

    • This reply was modified 1 year, 1 month ago by voodoochill.
    Plugin Author spencerfinnell

    (@spencerfinnell)

    Sorry, “Payment Cancelled Page” is being added in an upcoming release.

    When WP Simple Pay is activated pages are created and assigned to those settings, but only if they do not exist previously. Were your pages perhaps moved to the Trash?

    It doesn’t matter if you choose pages that WP Simple Pay created, they just need to be assigned to a published WordPress page. Ensure the page you have selected for “Payment Success Page” has the shortcode “[simpay_payment_receipt]” to output the payment receipt.

    Thread Starter voodoochill

    (@voodoochill)

    I deactivated the plugin awhile back (and deleted it)

    Then recently I thought I’d try it again so installed it.

    The success and failure pages I mentioned do refer to existing pages, but there is no shortcode, they are just pages that I have had for a while and nothing to do with this plugin

    Plugin Author spencerfinnell

    (@spencerfinnell)

    @voodoochill Please try the following:

    1. Visit “Pages > Add New”
    2. Add “Payment Confirmation” to the title and “[simpay_payment_receipt]” as a Shortcode to the page content.
    3. Visit “Pages > Add New”
    4. Add “Payment Failure” to the title, and anything you want to the page content.
    5. Visit “Simple Pay Lite > Settings > General”
    6. Assign the pages you just created to the two settings.
    7. Click “Save” at the bottom of the page.

    Does that resolve your issue?

    Thread Starter voodoochill

    (@voodoochill)

    Yes of course!

    I must have deleted those pages when deactivating and uninstalling, but when I reinstalled, the pages don’t get created.

    But I was also wondering, does this plugin create any database tables?

    Plugin Author spencerfinnell

    (@spencerfinnell)

    @voodoochill Great!

    WP Simple Pay Lite does not utilize any custom database tables. WP Simple Pay Pro creates a custom database table to manage Webhooks received from Stripe.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Error: Not a valid URL’ is closed to new replies.