Support » Plugin: Affiliates Manager » Error! Nonce Security Check Failed! Please submit your payment details again.

  • Resolved romonoutic

    (@romonoutic)


    Hello.. I’m having a serious issues with my website.. I’m getting the following error when in the last steps (after accept terms) the affiliate must to add their payment methods into a field form:

    Error! Nonce Security Check Failed! Please submit your payment details again.

    I already had this problem and the only way to solve was to restoring a backup. Because I’ve tried everything to solve it. I deactivated my plugins caches, even yoast SEO, I’ve deactivated the Security Plugins.. I cleared the cache from browsers and from my wp dashboard.. I tested created an account with several users using others navigators.. etc..

    If there any way to deactivated this option / error definitely ??

    I cannot give you the link of my website because it’s still in development I don’t want to be publicly announced here. But you can write to me to: ronys.work@gmail.com and I could share the link with you.

    Any clues or help to solve this will be really appreciated !
    Thank you for your help !

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hello again, I found that the problem is not related to any cache, theme or security issues, but to the “Permalink Manager Lite”. I’m using Oceanwp, Affiliate Manager and after deactivating the Permalink Manager Lite, the last step of the Affiliate Manager registration process started working again. This issue its not solved, because this plugin broke all permalinks when deactivating.

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi,

    Hello again, I found that the problem is not related to any cache, theme or security issues, but to the “Permalink Manager Lite”. I’m using Oceanwp, Affiliate Manager and after deactivating the Permalink Manager Lite, the last step of the Affiliate Manager registration process started working again. This issue its not solved, because this plugin broke all permalinks when deactivating.

    Are you talking about the following plugin permalink-manager If you are, we have no integration addon for this plugin. I don’t think this issue is related to our plugin.

    Kind regards

    Hello, thank you for your answer.

    As the problem for me is in the second part of the registration process, it doesn’t exist some way to avoid this second part of the process and still aprove users manually ?

    Because, It would be easy to add just a new field in the submission form, asking affiliates to add their Paypal emails and the Agreement Link. I don’t prefer to use the auto-aprove method for several personal reasons.

    I’ll appreciate your help in this issue!
    Thank you.

    Hi @mbrsolution,

    To whom it may concern, the issue is caused by a canonical redirect controlled by Permalink Manager. I am posting a temp. hotfix code snippet:

    function pm_fix_wp_affiliate_manager($request) {
    	if(!empty($_REQUEST['step'])) {
    		$request['do_not_redirect'] = 1;
    	}
    
    	return $request;
    }
    add_filter('request', 'pm_fix_wp_affiliate_manager', 999);

    Best regards,
    Maciej

    Hello! Thank you very very much! You fixed it !! It’s working excellent right know !

    Can I use this snippets code normally without limits of time ?? Could this code stop to work for some reason one day spontaneously ??

    Honestly I don’t use to leave reviews, but just only for this great and efficient support I’ll give you my five Stars! I can right know go on with my work !

    Thank you again ! Have a great day !

    Hi @romonoutic,

    yes, of course. Basically, my plugin will stop all redirect functions if ‘do_not_redirect’ query parameter is set. The snippet it is pretty simple and will stop working in the future.

    Best regards,
    Maciej

    Hi Maciej Bis,
    Thank you for your reply,

    The snippet it is pretty simple and will stop working in the future.
    Does this means that I’ll have the same problem in the future? or Does this means that you’ll fix definitely in the next update?

    Could you be more accurate when talking about the “future”? When?
    Do I need to be worry? Do I need to find another Affiliate plugin?

    I need to know If I can continue with the work on my website or If need to continue looking for a solution for this problem…

    Please let me know!
    Thank your for your time.

    Hi @romonoutic,

    the problem is solved and will not come back if you keep the snippet active. You do not need to change the affiliate plugin. As I mentioned above, the nonce was not validated because of the canonical redirect. The code snippet I provided will prevent the redirect, so the nonce will be parsed. This will work also with newer versions of Permalink Manager.

    Best regards,
    Maciej

    Hello Maciej Bis,

    https://wordpress.org/support/topic/best-support-ever-137/#new-post

    I’m Very Thankfully !
    Best Regards and Good luck !

    Hi @romonoutic,

    Thank you, but I am not related in any way with Affiliate Manager 😀 I am the author and developer of Permalink Manager.

    Now when your problem is solved, I would be also grateful if you could change your review for my plugin: Permalink Manger.
    https://wordpress.org/support/topic/error-404-all-website-permalinks-broken/

    I still wonder where exactly did you sent an initial message with a support request. Unfortunately, I have not received it.

    Best regards,
    Maciej

    • This reply was modified 1 month, 3 weeks ago by Maciej Bis.
Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.