Support » Plugin: W3 Total Cache » "Error: No zones matching custom domain" error message.

Viewing 15 replies - 1 through 15 (of 18 total)
  • I have the same problem…

    So, no comments about this one from developers? The latest update I have just installed now still has the same problem.

    I have the same problem. I’ve tried setting “Application URL” and “Callback URL” to my http://www.domainname.com, but still this error persists.

    The solution for me was to

    1) generate a new API key with NetDNA/MaxCDN by visiting http://cp.maxcdn.com/ and selecting APIs, then

    2) delete my existing Pull Zone that is tied to the CNAME that I want to use (cdn.domainname.com), then

    3) create a new Pull Zone in my NetDNA/MaxCDN account (more info on this step can be found here http://www.wpbeginner.com/wp-tutorials/how-install-wordpress-cdn-solution-maxcdn/), then

    4) update my DNS CNAME to this new zone (temporary url), and finally

    5) locate my “Alias” for my MaxCDN by going to Account > Settings at https://cp.maxcdn.com/account/settings

    I also needed to Bummer that the zone didn’t transfer over when I upgraded from W3 Total Cache to the latest version that supports the new API key management system from NetDNA/MaxCDN. No one’s fault here, but I wish it wasn’t such a surprise troubleshooting hour for me right now. But it’s working now!

    Thanks — Marty McGee, http://www.companyjuice.com

    Even after following what you said above, I still get the same error.

    Plugin Author Frederick Townes

    (@fredericktownes)

    The cname and Test CDN issue will be fixed in next release.

    Facing the same issue… When will be next release?

    This problem still happens with the new version. AFAIK, MaxCDN is now broke with W3 Total Cache.

    Moderator Marius L. J.

    (@clorith)

    I too was hoping that this update would address it, especially as it was posted 2 months ago that it would be fixed with the next release at the time.

    From what I can tell, it has nothing to do with the functionality in this version.

    Yes, the test button is broken… but it’s still serving my content from the cdn.

    It doesn’t in my case. The CDN is basically broken when I tried to enable MaxCDN caching in the past two versions of W3 Total Cache.

    Moderator Marius L. J.

    (@clorith)

    This is my problem as well, it’s as if it can’t verify the CDN without this test passing as I don’t get any buttons to add stuff like my theme files and such, it happily makes links to the cdn for everything in my theme though, which of course breaks the site.

    Confirmed this problem as well.

    The test button generates the error message even if the custom domain works perfectly fine from the MaxCDN side, and when I click Save All Settings, W3TC does begin using the custom domain regardless of the test button’s error message. So at least I can use my CDN.

    Incidentally, I can get ‘Test passed’ if I use the Temporary URL as provided in the Zone Configuration tab of the MaxCDN Pull Zone admin panel.

    Confirmed this problem as well.

    The test button generates the error message even if the custom domain works perfectly fine from the MaxCDN side, and when I click Save All Settings, W3TC does begin using the custom domain regardless of the test button’s error message. So at least I can use my CDN.

    Incidentally, I can get ‘Test passed’ if I use the Temporary URL as provided in the Zone Configuration tab of the MaxCDN Pull Zone admin panel.

    Ditto for the behaviour jshare’s reporting.

    (Damn splendid plugin otherwise Frederick.)

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘"Error: No zones matching custom domain" error message.’ is closed to new replies.