Support » Plugin: Uptime Robot Plugin for WordPress » Error msg: Connection to the Uptime Robot API was not possible.

  • Resolved mr_swede

    (@mr_swede)


    We are using v 2.0.10 of this plugin (since the latest version breaks our site). Since a few days we keep getting the error “Connection to the Uptime Robot API was not possible.”

    We have not updated wp or the plugin itself lately. As an attempt to fix the issue we re-created the Uptime Robot API token and pasted it in the plugin settings. Still no success…

    Any help is appreciated.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Aphotrax

    (@vlijmen)

    Hi,

    Could it be possible some server settings have been changed? I didn’t make any changes the last few days so I can not really find a reason what could be going wrong. Maybe your servers IP is blocked by the API?

    What is the issue you are facing with v2.1?

    Regards,
    Niels

    Hello Niels,

    Thanks for your superfast response. It is much appreciated 🙂

    We are using Amazon as host and we’ve not touched the server at all lately. We don’t have a clue to what could have caused the issue.

    The issue with v 2.1 of the plugin is that the page where the shortcode [uptime-robot] is used results in an HTTP 500 error.

    Plugin Author Aphotrax

    (@vlijmen)

    With pleasure, feedback from users also helps me of course.

    A 500 error can have many reasons unfortunately, to be sure what the reason is (on your host) you should enable wordpress debugging to catch the error that causes the page to load correctly.

    Thanks again.

    I’ve now disabled all other plugins, updated the Uptime Robot plugin to 2.1 and also installed the plugin “Debug Bar”, which obviously does not work with wp 4.6.1.. 🙁

    Can you recommend a debug plugin?

    Plugin Author Aphotrax

    (@vlijmen)

    You could use the build in debug option:
    https://codex.wordpress.org/Debugging_in_WordPress

    Put this in your wp-config:

    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);

    The erros will then be written to a log file in wp-content (or put display to true and you will see it on your screen, but other visitors also).

    Thanks for info.

    I’ve followed your instructions but no log file is written to the wp-content directory.

    Also tried another debug plugin (WP Log Viewer) but still no log file. Probably a permission issue..

    Plugin Author Aphotrax

    (@vlijmen)

    Of thats the case then you will have to set display to true I’m afraid. So just check the error and disable it again so your visitors won’t see the same error.

    I just released 2.1.1, this wasn’t focused on your issue but who knows it resolves it. 🙂

    • This reply was modified 2 years, 11 months ago by Aphotrax.

    Thanks Niels,

    I’ve updated the plugin to 2.1.1 and set define('WP_DEBUG_DISPLAY', true); and found this error:

    Notice: Undefined index: page in /home/public_html/wp-content/plugins/uptime-robot-monitor/uptime-robot-nh.php on line 86

    Still no Uptime Robot logs, either on the pages with the shortcode or in the settings page of the plugin.

    Plugin Author Aphotrax

    (@vlijmen)

    Thank you for reporting this, I have fixed that little issue in 2.1.2 now. But I don’t think that’s the reason for your issue.

    The API key is being saved correctly I assume? And resetting the cache doesn’t help either?

    I now get this error when clearing the plugin’s cache:

    Warning: Cannot modify header information - headers already sent by (output started at /home/public_html/wp-includes/formatting.php:5011) in /home/public_html/wp-includes/pluggable.php on line 1174

    Plugin Author Aphotrax

    (@vlijmen)

    That looks more like a reason that could cause your issue. I will look into this. Can you just let me know which PHP version you are running and which WP version?

    Thanks in advance

    We use WP v.4.6.1 and PHP v5.4.16.

    Plugin Author Aphotrax

    (@vlijmen)

    Ai, that version of PHP isn’t available on my server anymore so I won’t be able to test this. I’m afraid the issue is in there since a lot of php functionality has been depricated over the years. The minimum version I have tried it on is 5.5, but of course advised is to run it on PHP7 (or soon 7.1).

    I will do my best to find out what’s causing the issue and hopefully I can manage to fix it soon.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Error msg: Connection to the Uptime Robot API was not possible.’ is closed to new replies.