• Resolved decentris

    (@decentris)


    Hi Edward,

    plugin is working like a charm, just when I save the payment-configuration in WooCommerce-Settings I get these 2 error-messages from WordPress:

    Warning: Missing argument 2 for Ademti\Pwe\Gateway::show_icons(), called in /var/www/vhosts/s-pay.me/ico.s-pay.me/wp-includes/class-wp-hook.php on line 286 and defined in /var/www/vhosts/s-pay.me/ico.s-pay.me/wp-content/plugins/pay-with-ether/src/gateway.php on line 56

    Notice: Undefined variable: gateway in /var/www/vhosts/s-pay.me/ico.s-pay.me/wp-content/plugins/pay-with-ether/src/gateway.php on line 57

    What could that be?

    Thanks for your feedback.

    Best Wishes,
    Hannes

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author edward_plainview

    (@edward_plainview)

    That looks like a warning from the pay-with-ether plugin, which is unrelated to MCC.

    decentris

    (@decentris)

    Ah, yes. That was the error-message-causing thing.

    Just deactivated PWE-Plugin and the problem is solved now.

    The Pay-with-Ether – Plugin doesn’t fit my needs anyway, because it just uses the same Metamask-Button-API, but generates no QR or Copy-Fields like your wonderful plugin does. 🙂

    Just out of my personal curiosity: Could that be the cause of the problem, that Pay-With-Ether Plugin uses the same MetaMask-API?

    Best Wishes,
    Hannes

    Plugin Author edward_plainview

    (@edward_plainview)

    Nope. PHP warnings like the one above are almost always caused by not developing with WP_DEBUG mode enabled and therefore not seeing the warnings.

    Without having looked at the source code for the plugin, it seems like the developer was trying to use the $gateway variable before it was ready. No real biggie, really, but irritating for us that insist on using WP_DEBUG all the time: we see things that the plugin developers miss.

    decentris

    (@decentris)

    Yep, I completely agree.

    Issue hereby solved.

    Thank you very much, Edward.

    Best Wishes,
    Hannes

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Error-Messages when saving’ is closed to new replies.