WordPress.org

Support

Support » Plugins and Hacks » Fast Secure Contact Form » [Resolved] Error messages do not seem to match reality

[Resolved] Error messages do not seem to match reality

  • http://ssnet.org
    Using PHP 5.4.22

    I just got this automated message from my server. I appears to be sending me some of the code for the plugin. What does it mean – aside from the notification that the form is installed?

    Below are the recently upload scripts that contain code to send email. You may wish to inspect them to ensure they are not sending out SPAM.

    /home/ssnet/public_html/wp-content/plugins/si-contact-form/includes/class-fscf-options.php:654: if ( !function_exists( ‘mail’ ) ) {
    /home/ssnet/public_html/wp-content/plugins/si-contact-form/includes/class-fscf-options.php:655: echo ‘<div class=”fsc-error”>’ . __( ‘Warning: Your web host has the mail() function disabled. PHP cannot send email.’, ‘si-contact-form’ );
    /home/ssnet/public_html/wp-content/plugins/si-contact-form/includes/class-fscf-options.php:656: echo ‘ ‘ . __( ‘Have them fix it. Or you can install the “WP Mail SMTP” plugin and configure it to use SMTP.’, ‘si-contact-form’ ) . ‘</div>’ . “\n”;

    /home/ssnet/public_html/wp-content/plugins/si-contact-form/includes/class-fscf-options.php:3103: if ( !function_exists( ‘mail’ ) ) {
    /home/ssnet/public_html/wp-content/plugins/si-contact-form/includes/class-fscf-options.php:3104: echo ‘<div class=”fsc-error”>’ . __( ‘Warning: Your web host has the mail() function disabled. PHP cannot send email.’, ‘si-contact-form’ );
    /home/ssnet/public_html/wp-content/plugins/si-contact-form/includes/class-fscf-options.php:3105: echo ‘ ‘ . __( ‘Have them fix it. Or you can install the “WP Mail SMTP” plugin and configure it to use SMTP.’, ‘si-contact-form’ ) . ‘</div>’ . “\n”;

    /home/ssnet/public_html/wp-content/plugins/si-contact-form/includes/class-fscf-action.php:385: // Pass the Return-Path via sendmail’s -f command.
    /home/ssnet/public_html/wp-content/plugins/si-contact-form/includes/class-fscf-action.php:386: $result = mail( $email, $subject, $message, $header_php, ‘-f ‘ . $si_contact_mail_sender );
    /home/ssnet/public_html/wp-content/plugins/si-contact-form/includes/class-fscf-action.php:387: } else {

    /home/ssnet/public_html/wp-content/plugins/si-contact-form/includes/class-fscf-action.php:388: // the fifth parameter is not allowed in safe mode
    /home/ssnet/public_html/wp-content/plugins/si-contact-form/includes/class-fscf-action.php:389: $result = mail( $email, $subject, $message, $header_php );
    /home/ssnet/public_html/wp-content/plugins/si-contact-form/includes/class-fscf-action.php:390: }

    The mail function i not disabled.

    PHP “safe mode” is off (the default) on my server.

    And, by the way, to all appearances, my forms work. I can fill out a form, and it arrives at the expected email address.

    Awesome plugin!

    http://wordpress.org/plugins/si-contact-form/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Mike Challis

    @mikechallis

    Your server has some security program that alerts you when some code is installed that can send email. The message is alerting you in case some unauthorized person (a spammer or hacker) installed it.

    No problem found.

    Thank you so much, Mike 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Error messages do not seem to match reality’ is closed to new replies.
Skip to toolbar