Support » Plugins and Hacks » OpenSearchServer Search » error message while trying to index

  • When trying to index my site I get this warning, what is wrong??

    Warning: CURL failed to execute on URL “/schema?cmd=indexList” in /customers/4/b/5/annualreporting.info/httpd.www/wp-content/plugins/opensearchserver-search/lib/oss_abstract.class.php on line 169 Warning: Invalid argument supplied for foreach() in /customers/4/b/5/annualreporting.info/httpd.www/wp-content/plugins/opensearchserver-search/lib/oss_schema.class.php on line 52 Warning: CURL failed to execute on URL “/schema?index.name=&cmd=createIndex” in /customers/4/b/5/annualreporting.info/httpd.www/wp-content/plugins/opensearchserver-search/lib/oss_abstract.class.php on line 169 Warning: CURL failed to execute on URL “/schema?cmd=getSchema” in /customers/4/b/5/annualreporting.info/httpd.www/wp-content/plugins/opensearchserver-search/lib/oss_abstract.class.php on line 169 Fatal error: Call to a member function xpath() on a non-object in /customers/4/b/5/annualreporting.info/httpd.www/wp-content/plugins/opensearchserver-search/opensearchserver_admin.php on line 44

    http://wordpress.org/extend/plugins/opensearchserver-search/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Same error on wp 3.5.1 and oss 1.4 and plugin 1.2.1

    Plugin Author ekeller

    (@ekeller)


    This happen when the “Instance settings” are not saved. Can you check these settings and click on “Update settings” before creating the index ?
    (I understand that it is not really intuitive, we will improve this behavior in the next release)

    Plugin Author ekeller

    (@ekeller)


    We just released a new version. I suggest to upgrade to the last version, then check every panel of settings by click on all “Update … settings” button to be sure all options are saved. On the “Index settings” panel it is also important to create the index if you did not make it before.
    Let me know.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘error message while trying to index’ is closed to new replies.