WordPress.org

Forums

[resolved] [closed] Error message when updating plug-ins or themes (13 posts)

  1. littorine
    Member
    Posted 1 year ago #

    My site started running ultra-slowly shortly after updating to 3.7.1 a couple of weeks ago, and I've been getting this message when I try to update plug-ins. I have another WP site in a subdomain which has been at normal speed until I updated to 3.7.1 an hour ago, and now it has this message as well.

    Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in /home/pembe1/public_html/wp-includes/update.php on line 112

    Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in /home/pembe1/public_html/wp-includes/update.php on line 259

    Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in /home/pembe1/public_html/wp-includes/update.php on line 399

    I see in the forums that others are having this problem, but without a clear answer except to check for proxies. I checked, and I'm not using a proxy. My webhost regards update.php as a "vulnerable script" and says the problem is in the file, not the server. What else can I do?

    Thanks.

  2. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    My webhost regards update.php as a "vulnerable script"

    Unless the file was compromised, I find that statement quite intriguing.

    Do they think no one else hosts wordpress.org sites?

    Have you scanned your site at Sucuri?

    If that comes back clean, perform and manual update (to ensure that update.php was not compromised). If that fixes the matter, review issue with host again (what happened to update.php??)

  3. susannad
    Member
    Posted 1 year ago #

    I have this same problem. I've had 3.7.1 since it was released (whenever that was) and updated plugins after I upgraded to 3.7.1

    But now I can't add a new plugin or update an old plugin without getting that same error message

  4. WPyogi
    Forum Moderator
    Posted 1 year ago #

    @susannad - please start your own thread and include more relevant details in your thread:

    http://codex.wordpress.org/Forum_Welcome#Where_To_Post

    BTW, have you gone through:

    http://wordpress.org/support/topic/wordpress-37-master-list?replies=5

  5. susannad
    Member
    Posted 1 year ago #

    Apologies. Didn't mean to hijack.

    I'll keep watching this thread for replies to see if there's an answer to the problem

  6. littorine
    Member
    Posted 1 year ago #

    Thanks, Pioneer Web Design, for giving me a direction to go.

    The site was clean at Sucuri, so then I did a manual upload just of wp-includes/update.php, and that solved the problem.

  7. poddys
    Member
    Posted 11 months ago #

    Just wanted to add that if many of us are having exactly the same problem, adding your information to a single thread is surely better than creating dozens (or potentially hundreds) of threads all about the same problem. So in that case, adding this post to say that I too have this should be my way of helping to confirm there is a problem, and to hopefully add more information to help resolve it.

    In our case, our server is NOT set up to use SSL at all. I'm not sure if this is relevant to the error being generated, but I added a debug line to wp-content/update.php and the value of $ssl=1. Hoping this will help.

    -----------------------

    Edited to add.........

    Just saw this thread http://wordpress.org/support/topic/wp_http_supports-array-ssl-yeilds-true-on-a-local-server?replies=3 which shows that even if you do not have SSL enabled, if WP detects Curl as your 1st method of transport (which in our case is true), it assumes that SSL is active.

    I think this is likely to be the root of this problem.

  8. Just wanted to add that if many of us are having exactly the same problem, adding your information to a single thread is surely better than creating dozens (or potentially hundreds) of threads all about the same problem.

    You may think so... but that is simply not true in practice.

    There are way too many variables for us to claim that your issue is the EXACT same as the original poster.

    By contributing to this thread with (what you believe are relevant facts), we are getting further away from helping the original poster. It also makes it more difficult to re-read when following up to a post.

    By posting separate threads.. we are able to concisely see what each issue is.. and the steps that have been taken.

    When everyone posts on the same thread... it becomes a jumbled mess.

    It's like conferences with kids at school. You don't hold one conference and have all the kids and adults talk at the same time. You hold a separate conference for each kid... to make sure they get the attention they need and deserve.

    Same procedure here :)

    PS: By the way.. do you know you are replying to a thread that is 4 months old?

    Next time, create a new topic.. and reference this topic via a link if you feel it is relevant :)

  9. poddys
    Member
    Posted 11 months ago #

    Points taken Josh (having edited my post and seen your response).
    Will create a new topic.

  10. No worries at all.
    I don't work here... just my $0.02 ;)

  11. huemanfoo
    Member
    Posted 6 months ago #

    I've been getting this warning on almost EVERY update/installation!
    This morning I tried something - I added the following line in the end of my config.php file:
    define('WP_HTTP_BLOCK_EXTERNAL', false);
    AND IT WORKS!!! No more errors/warnings - all just runs smoothly!
    Just wanted to share this - not sure if it's really a fix...

  12. Ayman Makki
    Member
    Posted 6 months ago #

    Moderators keep asking to open our own threads and never solve the original problem. I face the same error message and looked for a solution in the forum and no luck at all!

  13. Andrew
    Forum moderator
    Posted 6 months ago #

    Actually the original problem was solved:

    The site was clean at Sucuri, so then I did a manual upload just of wp-includes/update.php, and that solved the problem.

    If you want to contribute to a thread you are free to do so, in fact you are encouraged, but don't post on a thread to discuss your own issue. Or to state "me too". Or to bump a thread.

    If you're not satisfied with the support given in this thread, or throughout the forums, then you'll want to use support elsewhere. Professional support from http://jobs.wordpress.net or http://codepoet.directory.com may be more suitable for you.

    Not going to tell you to create a new thread, but you're only disadvantaging yourself if you don't.

Topic Closed

This topic has been closed to new replies.

About this Topic