WordPress.org

Forums

Error message when updating multisite to 3.8 (12 posts)

  1. MoghillPat
    Member
    Posted 1 year ago #

    I have a couple of multisites running single sub sites at the moment and just did the upgrade to 3.8

    Everything goes fine until the database upgrade phase when I get this message: Warning! Problem updating http://www.(maindomain).co.uk/(subsite). Your server may not be able to connect to sites running on it. Error message: couldn't connect to host

    Site front ends appear to be working correctly but I still have a link to Upgrade Network in my control panel and when I try and use it I get the same error message as above.

    This has happened on two multisites now. Is it a glitch?

  2. What plugins are you running on those two networks?

  3. MoghillPat
    Member
    Posted 1 year ago #

    Thanks Mike

    The only ones both sites have in common are:

    Contact Form 7
    WooDojo
    myRepono Backup Plugin

    I try to keep plugins to a minimum.

    One has only one subsite(with nothing on it), the other 5 (with nothing or next to nothing on them). The one with five only named one of its subsites in the error message. Everything seems to be working just fine.

  4. Turn off myRepono Backup Plugin

    That's the only one I don't know :/

  5. MoghillPat
    Member
    Posted 1 year ago #

    *Mika* (sorry!)

    Nope. Just tried that, went back to Upgrade Network - same error message again.

    Wondering if it's a hosting issue but I really don't have a clue

  6. It may be, and normally at this point I would tell you to turn off ALL your plugins and try again... and yeah, I know that's a pain in the butt with Multisite, but it's the next debugging step.

  7. MoghillPat
    Member
    Posted 1 year ago #

    Well it's the first step, isn't it ;-)

    Done that, tried the upgrade, same error message. At least we've ruled out plug ins!

  8. Themes?

    Also did you check your server error logs?

  9. MoghillPat
    Member
    Posted 1 year ago #

    Only using two WooThemes, Canvas and the One Pager.

    I'll ask my hosting company as I'm pretty sure I don't have direct access to them.

    I installed another MultiSite today, using 3.8, and I just had a look in there. Even though I only have the root site set up and no sub sites, it just gave me the same error message , except this time it says it's the main site.

    Yet this site is running 3.8. I think it's a bug.

  10. jkhongusc
    Member
    Posted 1 year ago #

    Were you doing an "Upgrade Network"? If so...it sounds like your server cannot route to itself. Meaning if you did a curl or wget from the server to the upgrade url (itself), it would generate an error.

  11. I've seen a similar error when someone was running an HTTPS plugin, but you didn't say you were...

    Can you list ALL the plugins?

  12. MoghillPat
    Member
    Posted 1 year ago #

    I was indeed trying to do an 'upgrade network', jkhongusc. Sounds like you may have the cause.

    I'm not using an https plug in and no time now to post them all as I'm going away for the holidays.

    Since this is happening on three sites across different servers with the same host, I'm going to put a support ticket with them and refer them to the useful troubleshooting info on here.

    I'll report back, post a solution and close the ticket when I get one in case anyone else has this problem.

    Thanks for your help, both of you.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.