Support » Plugin: Ninja Forms - The Easy and Powerful Forms Builder » error message when trying to submit, after update

  • Resolved annamartindesigns

    (@annamartindesigns)


    I just performed the latest update and when I tested the form, I got this error message: Your email action “Admin Email” has an invalid value for the “TO” setting. Please check this setting and try again.

Viewing 14 replies - 1 through 14 (of 14 total)
  • annamartindesigns

    (@annamartindesigns)

    This is what I had in the field that is no longer working:

    Unique Pools & Spas <info@bu5ya7utocoverparts.com>

    Plugin Author Kevin Stover

    (@kstover)

    Hi,

    We’re working on tracking down the best way to validate complex email addresses. For the moment, you’ll need to use info@bu5ya7utocoverparts.com rather than the Name + Email.

    yulingdeng

    (@yulingdeng)

    Hi Mr. Kevin Stover,

    I encountered the same issue as annamartindesigns, for this web page that contains the form: http://nychildrenchoir4christ.org/audition-registration/

    Ever since I updated the plugin, I received that red sentence after pressing “submit”. The red sentence is: “Your email action “Admin Email Notification” has an invalid value for the “TO” setting. Please check this setting and try again.”

    I am not as knowledgeable as you or annamartindesigns, so do you mind to teach me exactly where I need to change, and what exactly I need to change to? The current form’s admin email setting is like this: http://nychildrenchoir4christ.org/wp-content/uploads/2017/01/Screen-Shot-2017-01-18-at-7.28.40-PM.png

    Can you tell me exactly what I need to do to resolve this? Thanks!

    annamartindesigns

    (@annamartindesigns)

    In the To field, put an actual email. That should fix it.

    yulingdeng

    (@yulingdeng)

    Hi Anna, thank you so much for the advice. However, I tried and it did not work for me, that was why I decided to post here. I tried the email of “info@nychildrenchoir4christ.org”, which is the admin email for the site, and I also tried putting my own gmail, which is just my name @gmail.com. Both did not work. I need to fix this urgent, because every day there are people using the form to register an event that is coming up in few days.

    Yuling

    Hi,

    I’m also experiencing this issue with just a standard email address in the “TO” field. The forms actually submit okay, but the error shows to the user so the user has no way of knowing that the form submitted successfully. This causes them to keep submitting the form a number of times before giving up and not knowing that the form ever went through.

    I’m using WP 4.7.1 and Ninja Forms 3.0.5. The error seems to have just started occurring this week with no changes to the form other than updating the plugin.

    Matt

    As a followup to this:

    Reverting back from 3.0.24 to 3.0.19 fixes the issue. (That was just the only version I already had a copy of so I reverted to that one. Not sure if 3.0.20-3.0.23 had the same issue as 3.0.24).

    Matt

    Hi Matt

    So great to know that installing the previous version fixes the issue. Do you have to rebuild all your forms from scratch after you uninstalled the new version and installed the old version? I took a lot of time to build my form and do not want to rebuild again. So I am thinking if I should wait for the author to fix the update’s bug or go for the route of the old version.

    Thanks!
    Yuling

    Having the same issue. Two active forms on my site with the same info in To field (default) and one works, the other displays this error message when users try to submit. Changed the problem form to my real email address and still get the message. Help please!

    • This reply was modified 8 months, 3 weeks ago by  katiesutton.

    TRY THIS:
    I had the same problem, but the error message was slightly misleading.

    The error read:

    Your email action “Admin Email” has an invalid value for the “TO” setting.
    Please check this setting and try again.

    However the problem was in the “REPLY TO” field (top right of the admin email form), where I had composed a full email address from parts of the entry form:

    {first} {last} <{email}>

    The form worked fine after I simplified this REPLY TO field to: {email}

    • This reply was modified 8 months, 3 weeks ago by  robbybutler.
    • This reply was modified 8 months, 3 weeks ago by  robbybutler.
    Plugin Author Kyle B. Johnson

    (@kbjohnson90)

    @robbybutler good catch. I submitted a patch to better report email action errors.

    Glad to be of help.
    Thanks, Kyle (@kbjohnson90), for the great service you provide all of us through Ninja Forms.

    Hello, I’m having the same issues with a brand new installation of Ninja Forms (Version 3.0.25) on an up-to-date installation of WordPress (4.7.2).

    I’ve tried replacing the TO and REPLY TO fields, but am met with the same error message (“Your email action “Admin Email” has an invalid value for the “TO” setting. Please check this setting and try again.”)

    Screen captures:
    Settings:
    https://www.dropbox.com/s/1idd45wwc0kawyt/Forms.png?dl=0

    Error:
    https://www.dropbox.com/s/h05zz3scgqrd2wq/error.png?dl=0

    Plugin Author Kyle B. Johnson

    (@kbjohnson90)

    @frenchliquor I would suggest contacting support at https://ninjaforms.com/contact

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘error message when trying to submit, after update’ is closed to new replies.