Support » Installing WordPress » error message when transferring between hosting accounts

  • Just transferred my site from its own domain hosting account to a “deluxe” account on GoDaddy that could host more than one domain. Nightmare. I had downloaded all the files first and GD helped me restore the WP database. Then, they told me it would “repopulate” within a few hours. This morning when I checked, I had this message:

    Warning: require_once(/home/content/94/9710994/html/DraperDesignOnline/wordpress/wp-load.php) [function.require-once]: failed to open stream: No such file or directory in /home/content/94/9710994/html/DraperDesignOnline/wordpress/wp-blog-header.php on line 12

    Fatal error: require_once() [function.require]: Failed opening required ‘/home/content/94/9710994/html/DraperDesignOnline/wordpress/wp-load.php’ (include_path=’.:/usr/local/php5_3/lib/php’) in /home/content/94/9710994/html/DraperDesignOnline/wordpress/wp-blog-header.php on line 12

    So based on that info, I tried to edit line 12 of the wp-blog-header.php file. This is what I changed it to:

    * Loads the WordPress environment and template.
    * @package WordPress

    if ( !isset($wp_did_header) ) {

    $wp_did_header = true;

    require_once(home/content/94/9710994/html/DraperDesignOnline/wordpress/wp-load.php’ );


    require_once( ABSPATH . WPINC . ‘/template-loader.php’ );


    Any helpful advice would be greatly appreciated. Many thanks! P.S., not sure I’ve selected the correct version. Set up the site in November with whatever version was current.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The problem seems to be that wp-blog-header.php needs the wp-load.php file, but can’t get it.

    I tried navigating directly to your wp-load.php file, to make sure it’s there. When I entered:

    I get a 404 Not Found error. When I enter:

    I get a page saying “Error establishing a database connection”.

    Can you check to see if you actually have a wp-load.php file? If not, that’s probably the issue.

    Hi Odai: I tried getting you some screen grabs to show what’s in the file, but can’t figure out a way to attach them. If there’s a way to send them directly to you, let me know. In the meantime…

    In the DraperDesignOnline folder on my hosting account, there IS a wp-load.php file, along with about 18 or other files that start with wp-. BUT (this may be part of the issue) there is a “wordpress” folder inside the DraperDesignOnline folder. Inside that folder there are 7 files: Index.php, wp-activate.php, wp-app.php, wp-blog-header.php, wp-comments-post.php, wp-config-sample.php, wp-config.php and 3 folders: wp-admin, wp-content, wp-includes. These 10 files seem to be duplicated directly in the DraperDesignOnline folder. Don’t know if the duplication could be an issue … if so, which files should I delete?

    Thanks for any help. As you can tell, I know little about wordpress (and as they say, a little knowledge is a dangerous thing!).

    P.S. This is the content of the wp-load.php file (all greek to me):

    * Bootstrap file for setting the ABSPATH constant
    * and loading the wp-config.php file. The wp-config.php
    * file will then load the wp-settings.php file, which
    * will then set up the WordPress environment.
    * If the wp-config.php file is not found then an error
    * will be displayed asking the visitor to set up the
    * wp-config.php file.
    * Will also search for wp-config.php in WordPress’ parent
    * directory to allow the WordPress directory to remain
    * untouched.
    * @internal This file must be parsable by PHP4.
    * @package WordPress

    /** Define ABSPATH as this file’s directory */
    define( ‘ABSPATH’, dirname(__FILE__) . ‘/’ );


    if ( file_exists( ABSPATH . ‘wp-config.php’) ) {

    /** The config file resides in ABSPATH */
    require_once( ABSPATH . ‘wp-config.php’ );

    } elseif ( file_exists( dirname(ABSPATH) . ‘/wp-config.php’ ) && ! file_exists( dirname(ABSPATH) . ‘/wp-settings.php’ ) ) {

    /** The config file resides one level above ABSPATH but is not part of another install */
    require_once( dirname(ABSPATH) . ‘/wp-config.php’ );

    } else {

    // A config file doesn’t exist

    // Set a path for the link to the installer
    if ( strpos($_SERVER[‘PHP_SELF’], ‘wp-admin’) !== false )
    $path = ‘setup-config.php’;
    $path = ‘wp-admin/setup-config.php’;

    define( ‘WPINC’, ‘wp-includes’ );
    define( ‘WP_CONTENT_DIR’, ABSPATH . ‘wp-content’ );
    require_once( ABSPATH . WPINC . ‘/load.php’ );
    require_once( ABSPATH . WPINC . ‘/version.php’ );


    require_once( ABSPATH . WPINC . ‘/functions.php’ );

    // Die with an error message
    $die = __( “There doesn’t seem to be a wp-config.php file. I need this before we can get started.” ) . ‘</p>’;
    $die .= ‘<p>’ . __( “Need more help? We got it.” ) . ‘</p>’;
    $die .= ‘<p>’ . __( “You can create a wp-config.php file through a web interface, but this doesn’t work for all server setups. The safest way is to manually create the file.” ) . ‘</p>’;
    $die .= ‘<p>‘ . __( “Create a Configuration File” ) . ‘‘;

    wp_die( $die, __( ‘WordPress › Error’ ) );

    Regarding screenshots – there’s no way to upload them to this forum, you have to upload them somewhere else and provide a link. One easy way is to upload pics to a service like Google Drive (5gb free storage), make them public, and Google Drive gives you a link to share with other people.

    By the way, are you enclosing that code in back ticks? There’s a button above the post writing area that says code that you can use to do it. Not enclosing code can cause the forum to mishandle your post, I think.

    Do you have still have backups of your site (especially the database) somewhere besides that server? Worst case scenario, you can always delete everything, re-install WordPress, and restore from the backups.

    I compared the code you posted to my own wp-load.php file, and they seem to match.

    Is it possible to download that “wordpress” folder to your computer, and then delete it off the server? It sounds like it’s all duplicate files, which is causing the problem. If not, you can re-upload the files from your computer.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘error message when transferring between hosting accounts’ is closed to new replies.