Support » Plugin: Contact Form 7 » Error message when sending the form

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Takayuki Miyoshi

    (@takayukister)

    I am having the same problem and your FAQ isn’t correct. There is something else wrong. The email will send if I add anything into the Message body: in the admin section but it only sends whatever I put in there. If I remove the text than I get the red box error. What could be the issue? Please help

    busybeemedia dot com/contact-us

    @busybeemedia

    RE: The email will send if I add anything into the Message body: in the admin section but it only sends whatever I put in there.

    That is how the plugin works – it only sends what you put in Mail | Message body: in “the admin section.”

    RE: If I remove the text than I get the red box error. What could be the issue?

    Having no text is most likely the issue – you are trying to send an empty email with no content.

    “it only sends what you put in Mail | Message body: in “the admin section.”…That makes no sense what is the plugin good for than. It should send what a visitor enters in the body of the message at the contact page not what we enter into the message body in the admin section????

    Having no text is most likely the issue – you are trying to send an empty email with no content. as mentioned if we don’t add text into the {admin section message body} than we get the email cant be sent error.

    My question is how do we get the form to work correctly? Are we suppose to place some kind of tag within the admin sections message body? If so what would that be?

    Thanks for your response.

    if we go and add content on the content page than we will get the email (only if we have content in the admin section of the plugin) but the email would not put what the visitor typed instead it sends whatever message me had in the message body within the admin section.

    I understand if I don’t put text in the message section on the contact page itself I may get an error but I fill out the whole form and get the error unless in the admin section (where you can change the settings on the plugin) there is text.

    If there is text within the admin “settings – message body” of the plugin than I do get the email but only get the text added there not what the visitor writes.

    Hope this makes sense, I think you confused the question with the answer you gave. Either that or I don’t understand your answer. If there is a specific short code I should place there please let me know 🙂

    See http://contactform7.com/getting-started-with-contact-form-7/ – that should give you answers to all your questions.

    We use the plugin on nearly all of our WordPress sites and it works brilliantly. However it does require that you spend a bit of time learning how it works.

    Once you do that I am sure you will see that there are really good reasons for the way it does all the things it does. As you use the plugin more and more you might be surprised at just how powerful it is.

    Nevermind. I found the answer at http://wordpress.org/support/topic/plugin-contact-form-7-form-submits-but-not-data-sent?replies=8 thanks for your help though 🙂

    Your are missing I think a basic concept with Contact Form 7.

    In “the admin section” the Form section is what the person using the form on the website sees.

    The Mail section which includes Message body is what you get via email. You need put any fields that you want in the email e.g. [your-name] in the Message body.

    Yes I absolutely was…LMAO I am glad I found that info. We usually use our own hand created contact forms but this seems like a pretty cool one so now that we have it working and I understand I am excited to play with it.

    I do appreciate your help. Thank you 🙂

    If this resolves your question, it helps others contributing here, if you can flag your post as [resolved].

    By the way the FAQ is NOT incorrect. It clearly didn’t give you what you needed but it is correct.

    Well it clearly isn’t a helpful FAQ page, I notice I am not the only one asking this same question. There are a lot of people so maybe something they would like to put on their FAQ, just a thought 🙂 The other FAQ pages put together seem to be very helpful so far.

    Thanks again for your help.

    How do I make this posting resolved? I usually don’t post here because our web guy takes care of these issues.

    The resolved/unresolved setting is on the right side of the post, under the “About this Topic” section. Just adjust it and hit the “Change” button.

    Plugin Author Takayuki Miyoshi

    (@takayukister)

    This is a thread opened by yaboariel and not yet resolved. busybeemedia can’t change the status because he is not the opener.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Error message when sending the form’ is closed to new replies.