Support » Plugin: WP Staging - DB & File Duplicator & Migration » error message when I try to access the staging site

  • Resolved mauroV8F5

    (@maurov8f5)


    I get the following error:

    Warning: require_once(/htdocs/public/www/staging/wp-content/plugins/advanced-ads/vendor/composer/autoload_real_52.php): failed to open stream: No such file or directory in /htdocs/public/www/staging/wp-content/plugins/advanced-ads/vendor/autoload_52.php on line 5 Fatal error: require_once(): Failed opening required ‘/htdocs/public/www/staging/wp-content/plugins/advanced-ads/vendor/composer/autoload_real_52.php’ (include_path=’.:/usr/share/php:/usr/share/pear’) in /htdocs/public/www/staging/wp-content/plugins/advanced-ads/vendor/autoload_52.php on line 5.

    An issue with advanced-ads plugin?

    thank you

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Rene Hermenau

    (@renehermi)

    @maurov8f5 This does not happen in previous versions of Advanced ads so I assume this is a new error caused by the composer autoloader mechanism.

    I’ve tagged Thomas @webzunft from advanced ads to that conversation. Maybe he has an idea. As there is no guarantee that he sees this conversation, it would also be a good idea to ask him directly about this issue and to open a new support ticket at the advanced ads support forum https://wordpress.org/support/plugin/advanced-ads

    Edit: I’ve installed the latest version of the ad plugin and I do not get that error.

    Are you using latest version of advanced ads? Any special settings or advanced ads add-ons you are using?

    Thanks, Rene, for making me aware of this ticket.

    maurov8f5, the issue you are describing comes up every few months. It always comes down to impartial downloads or incorrect writing permissions. I would suggest installing a new copy of Advanced Ads and see if that still happens.

    Thomas

    Thanks to both for replies. I ‘ve the last version, 1.10.12. Removing the plugin, the ads remain or I have to export before and then reimport?

    • This reply was modified 11 months, 1 week ago by mauroV8F5.

    If you don’t choose the “Remove data on uninstall” option in Advanced Ads > Settings > General then all settings and ads will be kept also when you remove the plugin. This setting is disabled by default.

    Thomas

    I ‘ve deleted the plugin, reinstalled, made the staging site but I got the same result, same error message.

    Plugin Author Rene Hermenau

    (@renehermi)

    Please post the content of the file /htdocs/public/www/staging/wp-content/plugins/advanced-ads/vendor/autoload_52.php and

    /htdocs/public/www/staging/wp-content/plugins/advanced-ads/vendor/composer/autoload_real_52.php

    here.

    Is the file /htdocs/public/www/staging/wp-content/plugins/advanced-ads/vendor/composer/autoload_real_52.php existing at all?

    • This reply was modified 11 months, 1 week ago by Rene Hermenau.
    Plugin Author Rene Hermenau

    (@renehermi)

    Please also check if the file exists on the live site. If it exists on the live site but not on the staging site I need to figure out why wp staging did not copy that file to the staging site.

    Btw. you can also reach me directly at support [at] wp-staging.com

    Thanks @webzunft for jumping in.

    This is the file from the live site:

    <?php

    // autoload_real_52.php generated by xrstf/composer-php52

    class ComposerAutoloaderInit7e435a20ca545f8783e709e05dbdc63b {
    private static $loader;

    public static function loadClassLoader($class) {
    if (‘xrstf_Composer52_ClassLoader’ === $class) {
    require dirname(__FILE__).’/ClassLoader52.php’;
    }
    }

    /**
    * @return xrstf_Composer52_ClassLoader
    */
    public static function getLoader() {
    if (null !== self::$loader) {
    return self::$loader;
    }

    spl_autoload_register(array(‘ComposerAutoloaderInit7e435a20ca545f8783e709e05dbdc63b’, ‘loadClassLoader’), true /*, true */);
    self::$loader = $loader = new xrstf_Composer52_ClassLoader();
    spl_autoload_unregister(array(‘ComposerAutoloaderInit7e435a20ca545f8783e709e05dbdc63b’, ‘loadClassLoader’));

    $vendorDir = dirname(dirname(__FILE__));
    $baseDir = dirname($vendorDir);
    $dir = dirname(__FILE__);

    $map = require $dir.’/autoload_namespaces.php’;
    foreach ($map as $namespace => $path) {
    $loader->add($namespace, $path);
    }

    $classMap = require $dir.’/autoload_classmap.php’;
    if ($classMap) {
    $loader->addClassMap($classMap);
    }

    $loader->register(true);

    return $loader;
    }
    }

    By the way, I’ve another question: once the staging site is done, where does it physically reside in the live site host or in the local PC? I ask you because I ‘ve noticed that the space on my local disk decreases after staging, and my goal is to provide access to external support for the staging site, So it should be on the remote host. Thank you.

    Plugin Author Rene Hermenau

    (@renehermi)

    Unfortunately, I can not see why it does not work.
    My offer is still valid, if you like to send me a mail and could show me the staging site I might be able to find out the reason for that issue

    > once the staging site is done, where does it physically reside in the live site host or in the local PC?

    The staging site is copied to a subfolder of your production website. It does not create any files on your local computer.

    Thank you Rene, I’ ve solved making the staging site without advanced ads, it’s ok for my tests.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘error message when I try to access the staging site’ is closed to new replies.