Support » Plugin: Simple Email Subscriber » error message when displaying on my page (WP newbie)

  • Hello:
    I am new to this WordPress thing and not an expert. I am using an ISP with WordPress 3.5.2 installed. There was a simple installation and activation procedure (no code to change or files to copy. i press buttons and it happened). After I added the Widget to my page and redisplayed the page, the following message is displayed on the page where the widget should be:

    Warning: include_once(/home/secure37/public_html/htdocs/wp-admin/includes/template.php) [function.include-once]: failed to open stream: Permission denied in /home/norwal10/public_html/wp-content/plugins/simple-email-subscriber/admin_pages/subscription_widget.php on line 2

    Warning: include_once() [function.include]: Failed opening ‘/home/secure37/public_html/htdocs/wp-admin/includes/template.php’ for inclusion (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/norwal10/public_html/wp-content/plugins/simple-email-subscriber/admin_pages/subscription_widget.php on line 2

    Note it refers to a directory structure i do not have. the sub dir htdocs does not exist.
    e.g. the error message refers to:
    public_html/htdocs/wp-admin/includes/template.php

    I have:
    public_html/wp-admin/includes/template.php

    what code do I need to adjust where?
    Thank you in advance for your help.

    http://wordpress.org/extend/plugins/simple-email-subscriber/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author phil88530

    (@phil88530)

    Hi:

    by the look of it, (I might be wrong), it seems not a coding issue, but a permission issue. where someone need to help you setup the files to have a read (r) permission to your plugin(s) folder, using the “chmod” command.

    Its interesting to hear this issue, and let me know the progress.

    I will go back and check the file permission for the default plugin as well tonight, hope that might help

    I even put 777 as my permissions and I still get the same thing above.
    This plugin is what I’ve been looking for too. I haven’t found another plugin that will do what this is supposed to do either.

    Can we get an update?
    Is there an issue because I have the latest wordpress 3.5.2?

    I think you have a path issue with this plugin?

    My error…

    Warning: include_once(/home/content/54/8787854/html/wp-admin/includes/template.php) [function.include-once]: failed to open stream: No such file or directory in /home/content/54/8787854/html/watchdogtest/wp-content/plugins/simple-email-subscriber/admin_pages/subscription_widget.php on line 2

    Warning: include_once() [function.include]: Failed opening ‘/home/content/54/8787854/html/wp-admin/includes/template.php’ for inclusion (include_path=’.:/usr/local/php5/lib/php’) in /home/content/54/8787854/html/watchdogtest/wp-content/plugins/simple-email-subscriber/admin_pages/subscription_widget.php on line 2

    Plugin Author phil88530

    (@phil88530)

    Dear bradzter:

    the warning show that it has failed to open the /wp-admin/includes/template.php file, it might because of a permission denied as well (I am not entirely sure)

    however, from the look of it, it seems that you are able to run the plugin now, it might not work because of can’t load your wordpress template.php file.

    try to check the permission for your wordpress directory.

    btw, I think chmod 755 would be good enough instead of 777.

    hope that helps.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘error message when displaying on my page (WP newbie)’ is closed to new replies.