Support » Installing WordPress » Error Message: Server running PHP version 4.4.9

  • Resolved mahastew

    (@mahastew)


    Just uploaded the WordPress files to my server and received this error message when trying to activate:

    “Your server is running PHP version 4.4.9 but WordPress 3.4.2 requires at least 5.2.4.”

    Does this mean I’m precluded from being able to use WordPress through my web host, or can I somehow configure things to make it work?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hello Mahastew,

    May I know if you are hosting your WordPress with a hosting provider?

    Here is a link for more details on switching to PHP5.
    http://codex.wordpress.org/Switching_to_PHP5

    You can request your host support team to upgrade to PHP5 else you will still need to to use version 3.2.1 on PHP4.

    Thanks for your repsonse. Yes, I’m with Lunarpages. Where can I download v3.2.1?

    Stew

    Max

    (@clementsm)

    Before you do that, contact your host, most hosts have both php4 and php5 installed and they can just switch your site to run through the php5 interpreter.

    You will have issues with lots of things moving forward if you stay on php4 as plugin writers, theme writers and so will start to write code that is not compatible with php4.

    Will do, thanks!
    S

    Hi Stew,

    You can get WordPress past version here.
    http://wordpress.org/download/release-archive/

    But it is not recommended due to security concern. How about try submitting a ticket to Lunarpages to upgrade their PHP version. No harm asking. 🙂

    Mahastew i just dealt with this exact problem myself, so I thought i would help out.

    I had LunarPages as well, so log into your CPanel go to php configuration under the software heading. At the top there is a drop-down menu, select php5 and there you have it!

    I was super surprised that it was so simple, so i hope that you have already solved this issue but if not that this helps.

    Brilliant! Thanks so much. i had given up on using WordPress. Lunarpages tried to tell me I had to upgrade my account to the tune of $120 per years to be able to use PHP5. Ridiculous!

    Stew

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Error Message: Server running PHP version 4.4.9’ is closed to new replies.