Support » Plugin: Username Changer » ERROR MESSAGE, Plugin seriously needs update.

  • It’s 3/24/18.

    I just installed Usernmae Changer. I was looking forward to using it.

    But of concern was that it was last updated 5 months ago:
    Version: 3.1.3 Last updated: 5 months ago
    Requires WordPress Version:3.0
    Tested up to: 4.7.9

    WordPress will soon be releasing version 5.0 with significant changes. So I worry about this plugin’s compatability.

    Currently, in it’s Dashboard Pane: Settings > Username Changer > Support, I get the following error message as soon as I activated the plugin.

    Given this error message, I am deactivating this plugin and will wait for an update from the author.

    Hopefully it isn’t a dead plugin.

    ————————————————–

    ( ! ) Warning: count(): Parameter must be an array or an object that implements Countable in /app/public/wp-content/plugins/username-changer/includes/libraries/s214-settings/source/class.s214-settings.php on line 207

    Call Stack
    # Time Memory Function Location
    1 0.0000 402408 {main}( ) …/options-general.php:0
    2 0.0003 403080 require_once( ‘/app/public/wp-admin/admin.php’ ) …/options-general.php:10
    3 0.9366 11000512 do_action( ) …/admin.php:224
    4 0.9366 11000888 WP_Hook->do_action( ) …/plugin.php:453
    5 0.9366 11000888 WP_Hook->apply_filters( ) …/class-wp-hook.php:310
    6 0.9366 11002016 S214_Settings->render_settings_page( ) …/class-wp-hook.php:286

    Username Changer Support

    System Info

    ( ! ) Warning: count(): Parameter must be an array or an object that implements Countable in /app/public/wp-content/plugins/username-changer/includes/libraries/s214-settings/source/modules/sysinfo/class.s214-sysinfo.php on line 178

    Call Stack
    # Time Memory Function Location
    1 0.0000 402408 {main}( ) …/options-general.php:0
    2 0.0003 403080 require_once( ‘/app/public/wp-admin/admin.php’ ) …/options-general.php:10
    3 0.9366 11000512 do_action( ) …/admin.php:224
    4 0.9366 11000888 WP_Hook->do_action( ) …/plugin.php:453
    5 0.9366 11000888 WP_Hook->apply_filters( ) …/class-wp-hook.php:310
    6 0.9366 11002016 S214_Settings->render_settings_page( ) …/class-wp-hook.php:286
    7 0.9445 11019536 do_settings_sections( ) …/class.s214-settings.php:248
    8 0.9445 11019536 do_settings_fields( ) …/template.php:1337
    9 0.9446 11019536 S214_Settings->sysinfo_callback( ) …/template.php:1378
    10 0.9446 11019848 S214_Sysinfo->get_system_info( ) …/class.s214-settings.php:980

    ————————————————–

    • This topic was modified 1 year, 4 months ago by  .
  • The topic ‘ERROR MESSAGE, Plugin seriously needs update.’ is closed to new replies.