Support » Plugin: Gmail SMTP » Error Message on Test Email

  • Resolved rcarroll1989

    (@rcarroll1989)



    My host is justhost.com. Their support has said I have port 587 open and they support SSL and TLS. my application was granted access but I still fail with the test email.

    This is the error message:
    2018-01-19 15:44:37 Connection: opening to smtp.gmail.com:587, timeout=300, options=array ()
    2018-01-19 15:48:51 Connection failed. Error #2: stream_socket_client(): unable to connect to smtp.gmail.com:587 (Network is unreachable) [/home1/gatherj2/public_html/wp-content/plugins/gmail-smtp/PHPMailer/class.smtp.php line 298]
    2018-01-19 15:48:51 SMTP ERROR: Failed to connect to server: Network is unreachable (101)
    SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

    My Server info is below
    OS: Linux just127.justhost.com 3.10.0-714.10.2.lve1.4.79.el6h.x86_64 #1 SMP Thu Jan 4 14:26:00 EST 2018 x86_64
    PHP version: 7.0.25
    WordPress version: 4.9.2
    WordPress multisite: No
    openssl: Available
    allow_url_fopen: Enabled
    stream_socket_client: Available
    fsockopen: Available
    cURL: Available
    cURL Version: 7.24.0, OpenSSL/1.0.0

Viewing 1 replies (of 1 total)
  • barcombeboy

    (@barcombeboy)

    Hi

    We had a similar problem at EUKHost. Our site was run on our VSL and there’s a setting in WHM:

    Security Center/SMTP Restrictions

    which, if enabled will stop the whole VSL being able to use external mail servers (like Google’s). To get GMAIL SMTP plugin to work we had to disable SMTP Restrictions

    I hope that helps.

Viewing 1 replies (of 1 total)
  • The topic ‘Error Message on Test Email’ is closed to new replies.