[resolved] [closed] Error message messing up my backend (22 posts)

  1. alienalias
    Posted 3 years ago #

    A few different functions of the Admin area of my site have stopped working.

    For example, I have custom menu's that I use. I have attempted to move one of my submenu items up a slot because it was out of order. When I click Save, the entire menu disappears, is deleted, and I get a funky set of bullet points all down the right side of the website on every page. So, I revert/restore to a backed up version. Tried again, does it again.

    It is not a plugin issue as I have been using the same plugins for months, and last did updates a week earlier and everything worked fine until today.

    My site itself works fine, but there are a bunch of weird things going on with my WP Admin area. I am getting these 2 error messages at the bottom of my screen:

    Warning: Unknown: open(/tmp/sess_ee22848894927abd6f905697457fa2cc, O_RDWR) failed: Permission denied (13) in Unknown on line 0

    Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0

    Please don't answer too technically jargony, because I am rather novice at this and not too code competent, although I do follow instruction well.

    Please help!

  2. alienalias
    Posted 3 years ago #

    THANKS for all the answers everybody! Sheesh, NOT.

    This looks like a COMMON problem and NO ONE is helping ANY of us!!! Here is another one.. at least people have tried in this thread:


    Gee, here's another one with zero answers:


    There are threads throughout this forum about this problem but NO ONE IS HELPING US. Can I vent and say this forum sucks because people cherry pick what they will answer and what they will not? I am currently buried 6 pages deep in "Troubleshooting" with nigh an answer to this point. Booooooooooooooo!

    I have tried:
    Disable all plugins
    Try a different browser &
    Try a different theme
    To NO AVAIL.

    ANY worthy helpers out there? PLEASE???? I have my managed-server support people on this, have actually contacted a third party WP "expert" for paid support, and this place... and this place I can't even get someone to answer and the others waiting for response. I'd appreciate a "Shove it up your butt" better than the absolute silence!

  3. WPyogi
    Forum Moderator
    Posted 3 years ago #

    I'm sorry you have not gotten the help you need here, but these forums are staffed entirely by volunteers, so depending on when you happen to post, who happens to be around, and what the issue is, you may or may not get a quick or sufficient answer. We do the best we can - but given that the help here (and WordPress itself) is free, perhaps your rant is a bit misplaced.

  4. alienalias
    Posted 3 years ago #

    Hey, it solicited a response! Better than the silence, as I said before. If my rant is misplaced, where should I place it? What about your rant on my rant? kidding! :)

    I tried begging in my thread title, figured I'd try a little somethin-somethin' else. I seriously need help on this and it looks like many people are having the same exact prob since this update.

    [Moderator note: If you want to emphasise words, use italics or bold. Don't uppercase the word.]

  5. Andrew Nevins
    Forum moderator
    Posted 3 years ago #

    You can receive urgent help here http://jobs.wordpress.net

  6. @alienalias: chill out.

    We're all volunteers around here.

    Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0

    That's a server error, not a WordPress error.

    and it looks like MANY people are having the same exact prob since this update.

    Wrong. Try searching these forums for that error; it's a server issue having to do with php configs. It has nothing to do with the threads you linked. Talk to your server people.

  7. alienalias
    Posted 3 years ago #


    Whether the error messages are server related or not, you are probably right, as that is not my cup of tea. I'm a technical idiot. But it is inarguable that others are having my issue. This thread:

    Shows this guy describing the exact same issue I'm having to a "T". He wrote, "I'm trying to add a new menu item (in this case, Dyson Spares). I can create the menu item, but when I drop a category into the menu and save it, it says it's saved but the category disappears leaving the menu blank.

    I've also noticed that if I make any changes to existing menus, not only do they not save, they disappear."

    This is EXACTLY what is happening to me. Anything better you might be able to offer, or advice as to what I should suggest to my server side guys? Sorry if you didn't like my approach. The silence was deadening so out of desperation I decided to go the squeaky wheel route, in hopes of getting some grease! :)

  8. WPyogi
    Forum Moderator
    Posted 3 years ago #

    @alien - you need to look at the error message you are getting, NOT the symptom you are seeing in the dashboard. Your underlying problem is not the same as the other guy's.

    See these threads which are similar to yours:


  9. alienalias
    Posted 3 years ago #

    WPyogi... I guess you didn't get the memo. You are not allowed to type words in caps as according to the moderator, above. ;) Maybe this is preference, instead of TOS? I don't get it.

    Anyway, the error messages are now resolved, but the issue persists, so they are apparently not interconnected.

    Exactly as is occurring with the other post I referenced, every time I try to save my custom menu the entire menu is deleted, ceases to exist, and I have to restore to a backup. So, ANY other suggestions? Anybody else had this problem or been able to fix it? I've found at least 3 other threads here involving issues with the custom menu disappearing when the user tries to save it. Please HELP!

    EDIT note- Maybe the above is why some use caps... I highlighted one word and clicked to bold and italicize, and it italicized 2+ sentences. It's silly to demand people can't use caps to accentuate a point when people are habitually on blogs where caps are the standard used to accentuate. Just silly... :(

  10. WPyogi
    Forum Moderator
    Posted 3 years ago #

    Okay, if those are resolved, great, you're making progress. Now start with the steps in this thread:


  11. Andrew Nevins
    Forum moderator
    Posted 3 years ago #

    Have you contacted your hosting providers regarding the issue Songdogtech pointed out?

  12. alienalias
    Posted 3 years ago #

    Andrew- Thanks. Yes. The error messages are resolved. This was suggested:
    "...which leads me to believe that when you are connecting to the wp-admin it is attempting to load a session file from the /tmp folder that is no longer valid.

    I've cleared out the /tmp folder now, so what I'll need to you to do on your end is log out of the admin section and then clear your browser cache. Once that is done please log back in and navigate to the same area, the error should be removed at that point."

    I did that and error messages are resolved and gone. But issue persists with being unable to save custom menu. I have custom menu with about 6 main menu items and guessing 40 child and submenus. If I try to add a new menu item or make a slight change and then save, it simply deletes my menu and creates about 40 bullet points deep down the right side of my page.

  13. alienalias
    Posted 3 years ago #

    By the way, I DO appreciate everybody's help and effort even if I'm a little bit of a smart alec at times! :)


  14. Andrew Nevins
    Forum moderator
    Posted 3 years ago #

    Can you check whether there are any JavaScript errors thrown, by following the Troubleshooting protocol (above) section for jQuery http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors ?

  15. alienalias
    Posted 3 years ago #

    Is there a way to add screenshots here?

  16. Andrew Nevins
    Forum moderator
    Posted 3 years ago #

    Yes, you can paste screenshots here http://snag.gy/ then post here the URL given from that website.

  17. alienalias
    Posted 3 years ago #

    I'm just wondering if a visual of the problem will help. This is probably easier than the screen grab, but I didn't want to link to my site b/c it's not live yet and won't be until Feb 15th. Anyway, my site is http://thechristiandude.com . If you take a quick look, you'll see that my menu has been migrated to the right hand side of the screen, it has erased all menu items, and added about 40 bulletpoints going down the right hand side of the page.

    Didn't know if that might help people visualize this better and propagate some different ideas. Worth a try...

  18. alienalias
    Posted 3 years ago #

    PS- I did add this to the jobs board and will pay someone a reasonable fee (via Paypal) to resolve this for me, as I imagine it to be a quick and easy fix for someone much more competent than me. In the meantime, suggestions still welcome. I'm trying to figure out how to do the previously troubleshooting advised, but I'm a dummy with this stuff.

  19. WPyogi
    Forum Moderator
    Posted 3 years ago #

    I looked at your site and it looks like something got messed up with the menu - an element around the menu is missing a CSS class that relates to the menu. Not sure how to fix that, but you could also try asking on the theme forums:


  20. alienalias
    Posted 3 years ago #

    @WPyogi- THANKS! I am approaching this via the Trifecta... I am here, at the forum you linked to at mysitemyway, and working on it server side with the guys who manage my servers. That is a great suggestion though and I will bring that up in the thread I have working over there.

    Still taking suggestions and willing to pay someone to resolve if we can't get it figured it out though. :)

  21. kmessinger
    Volunteer Moderator
    Posted 3 years ago #

    Since the error message problem has been solved you should start any thread with a topic more closely describing your current problem.
    That will help others searching for menu problems.

    I am marking this resolved and closing it.

  22. Okay, I can answer the main questions here, but I have to tell you, there is some technical jargon involved. No getting around it.

    Here's the error messages you posted:

    Warning: Unknown: open(/tmp/sess_ee22848894927abd6f905697457fa2cc, O_RDWR) failed: Permission denied (13) in Unknown on line 0
    Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0

    First, that error is coming from your webserver. Specifically, it is telling you that the session.save_path setting in the PHP configuration is set to a directory (/tmp, in this case), that you don't have permission to write files to.

    What does that mean? Bottom line: it means your server is configured incorrectly and you need to complain about it to your web hosting company. This is a problem in the underlying server configuration. If they won't fix it or say that it is somebody else's problem or that it is not supported in some way, then they are feeding you a total bunch of nonsense and I would highly recommend getting a better web hosting company in such a case.

    Next, the problem with your menu not saving is also a server problem, but a different one. Basically, some servers have configurations that severely limit the number of variables that the page can send to them. The upshot of this is that when the menu you're making grows beyond a certain number of items, it can't send updates to it anymore, as you have discovered.

    This is a known issue in WordPress. Recent updates have reduced the number of variables being sent, and thus increased the size of the possible menus on servers with these configurations, but the underlying problem isn't exactly fixable by WordPress itself at this point in time.

    The most common cause is using "suhosin" on the server with a configuration that limits the number of "post vars". Changing the configuration to increase this limit, or disable it entirely, is the only real solution at present. Again, this comes back to asking your web host how they can help you.

    TL;DR: Talk to your web host and say this:
    - I need the web server to have PHP Sessions configured correctly (session.save_path).
    - I need the web server to have display_errors set to "false".
    - I need the web server to have suhosin disabled, or configured to have a higher limit on the number of suhosin.post.max_vars.

    They may say that you can do these things yourself via a custom php.ini file or via the .htaccess. Or they may say that they can't do it at all.

Topic Closed

This topic has been closed to new replies.

About this Topic