W3 Total Cache
error message 'It appears Minify URL rewriting is not working' (4 posts)

  1. Jeevanandam Madanagopal
    Posted 2 years ago #

    Hello -

    .htaccess has write permission, I'm getting below error message:
    It appears Minify URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess. Or if using nginx verify all configuration files are included in the main configuration fail (and that you have reloaded / restarted nginx).



  2. vijayrajah
    Posted 2 years ago #

    I'm having the same issues.. I have a fresh install of WP-3.5.1 with Better WP security -- 3.4.9 & W3tc --

    I tried adding the wp-content/w3tc-config to Better Wp security whitelist, as suggested

    I made sure that .htaccess *is* writable by the Apache process... (chmod 0660). I also have allowed .htaccess (with Allowoverride all in apache config)

    Even after disabling Better WP security.. I'm still having the same issues....

    Not sure how to proceed...

  3. vijayrajah
    Posted 2 years ago #

    Ok, I did a fresh install of WP and installed W3tc with no other plugin...

    I still got the same error. I investigated a little... Found this in my apache log

    199.102.x.x [15/Apr/2013:12:03:59 +0530] http://www.mydomain.tld - "GET /video/video/wp-content/cache/minify/000000/w3tc_rewrite_test HTTP/1.0" 404 4004 -% 170250us

    The issue here is that /video (URI) is repeated twice. (/video/video)

    If i repeat the request (with wget) with /video/wp-content/cache/minify/000000/w3tc_rewrite_test i get an 'OK' (note single /video )

    May be this is a bug ? misconfiguration?

  4. achsanos
    Posted 2 years ago #

    In Performance >> Minify >> General, try to uncheck the option Rewrite URL structure, maybe it works.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic