Support » Plugin: Google Maps - Google Maps Builder for WordPress » Error message in version 2.2.0

  • Resolved papijo

    (@papijo)


    When upgrading or installing new version 2.2.0 of this plugin I get this error:
    Fatal error: Class ‘Hugeit_Maps_Shortcode’ not found in […]\wp-content\plugins\google-maps\googlemap.php on line 157

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hello,
    Sorry for the inconvinences
    Please tell me which part of the plugin did you meet this error , we will check it immediatelly

    Hi!
    Further to my previous post I have found out that Google Map version 2.2.0 works fine on my online WP sites.
    I only get the Fatal error message (which crashes the entire WP site) on my localhost WP sites.
    Localhost is on Windows 10, PHP Version 5.6.8, WP Version 4.6.1.
    I can provide more details if needed.

    Hello
    dear @papijo
    Sorry for the issues
    An update will become available during the next 24 hours. Please, make sure to update your plugin

    I am sorry your issue also may be from server settings, so just in case please tell us check it , drop a message to info@huge-it.com

    Hello and thanks for your reply. As I said in my second post, I am only getting the error on my localhost wp sites. Here are my settings:

    Localhost is on Windows 10, PHP Version 5.6.8, mysql version mysqlnd 5.0.11-dev -20120503

    Previous version of Google Map worked OK on my localhost, all other plugins are working OK. There must be something in version 2.2.0 which makes it conflict with a localhost installation.

    Thanks, as i have said that we suspect the reason from your server’s configurations, could you contact us please? info@huge-it.com

    Hi,

    I have the same Issue at the first installation on plugin.

    When a try to activate the plugin ver. 2.2.3 I take the following error crashing my site

    Fatal error: Class ‘Hugeit_Maps_Shortcode’ not found in …\wp-content\plugins\google-maps\googlemap.php on line 157

    I work in localhost with XAMPP 5.6.3, php 5.6.3., WIN 7, theme Baskerville

    Can you help me?

    Thank You

    Felix

    • This reply was modified 3 years, 6 months ago by felixtayler1.
    • This reply was modified 3 years, 6 months ago by felixtayler1.

    Hi Felix,
    Further to my messages in this forum I contacted HugeIt support with a diagnostic and a solution. They said they would fix the bug in new releases, but apparently there has not been any new release since 2.2.3.

    Please try my fix and report.
    Problem
    At the beginning of script googlemap.php there is a call to require(‘config.php’);
    On my online WP site, this works OK.
    On my localhost site, for some reason, that call does not find the required config.php file.

    Solution (tested both on local and online wp sites)
    In script googlemap.php
    replace: require(‘config.php’);
    with: require(plugin_dir_path(__FILE__) . ‘/config.php’);

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Error message in version 2.2.0’ is closed to new replies.