Support » Plugin: ThirstyAffiliates Affiliate Link Manager » Error message: Failed to load plugin url

  • Resolved karliewharlien

    (@karliewharlien)


    Hi. As the title says, this error message turns up when I try to write new posts.. This happened compeletely randomly, I havent made any changes to the site nor installed any new plugins..

    Error Code:

    Failed to load plugin url: https://vpnbasen.se/wp-content/plugins/thirstyaffiliates/js/lib/thirstymce/editor-plugin.js

    https://prnt.sc/qtlyxj

    I cant even write any new posts anymore..

    I´ve edited the HTaccess file but the issue persists..

    # BEGIN Cache-Control Headers
    <ifmodule mod_headers.c>
    <filesmatch “\\.(ico|jpe?g|png|gif|swf|gz|ttf)$”>
    Header set Cache-Control “max-age=2592000, public”
    </filesmatch>
    <filesmatch “\\.(css)$”>
    Header set Cache-Control “max-age=1592000, public”
    </filesmatch>
    <filesmatch “\\.(js)$”>
    Header set Cache-Control “max-age=1592000, private”
    </filesmatch>
    <filesmatch “\\.(html|htm)$”>
    Header set Cache-Control “max-age=7200, public”
    </filesmatch>
    # Disable caching for scripts and other dynamic files
    <filesmatch “\.(pl|php|cgi|spl|scgi|fcgi)$”>
    Header unset Cache-Control
    </filesmatch>
    </ifmodule>
    # END Cache-Control Headers

    That code snippet doesnt seem to work in my case. Please help:)

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author Caseproof

    (@caseproof)

    Have you tried deleting and re-installing the plugin?

    karliewharlien

    (@karliewharlien)

    No, but if I choose to do so, will the affiliate links still be there or will they disappear? I have about 90 of them so it´s kind of a big deal in my case..

    Plugin Author Caseproof

    (@caseproof)

    The links are stored in the database so deleting and re-installing the plugin will not affect them.

    karliewharlien

    (@karliewharlien)

    I just reistalled it, the problem remains. Its really strange since I didnt change anything:/

    Plugin Author Caseproof

    (@caseproof)

    I found this which seems similar: https://wordpress.org/support/topic/failed-to-load-plugin-url-4/

    Might be a plugin conflict.

    Where do you see the errors (what pages are you on when you see them)?

    I guess the next step is to temporarily disable other plugins and see if the errors go away.

    karliewharlien

    (@karliewharlien)

    I see it when I try to edit new posts, but also when I´ll revisit old posts and scheduled posts in the editor.

    I´ll try to deactivate the other plugins one after one, I´ll be back once that´s done..:)

    karliewharlien

    (@karliewharlien)

    The error code goes away when I´ll deactivate “Disable Gutenberg”..

    But since I absolutely hate the block editor I´ll keep on deactivating other plugins instead..

    karliewharlien

    (@karliewharlien)

    It doesnt seem to work, I´ve deactivated everything except the theme plugins, which have to be activated..

    https://prnt.sc/qtmk98

    I also use Cloudflare, if thats relevant somehow..

    Plugin Author Caseproof

    (@caseproof)

    So the Disable Gutenberg plugin seems to be the cause then?

    karliewharlien

    (@karliewharlien)

    Yes. The error message goes away when I disable “Disable Gutenberg”..

    Plugin Author Caseproof

    (@caseproof)

    Okay, we will investigate it. I might recommend that you use Classic Editor plugin instead in the meantime: https://wordpress.org/plugins/classic-editor/

    karliewharlien

    (@karliewharlien)

    The error message comes back when I activate the “Classic Editor” plugin..

    Well, in the worst case i guess I´m stuck with the block editor..

    karliewharlien

    (@karliewharlien)

    I was i little quick there.. please do so and get back to me if you find anything:)

    karliewharlien

    (@karliewharlien)

    Update:

    The error code returns once I visit posts created in the classic editor..

    https://prnt.sc/qtmvv4

    But it goes away when I visit posts created in the block editor..

    https://prnt.sc/qtmwfp

    And as I mentioned before, I wont appear when I´m creating new posts in the block editor..

    Well thats about it, please let me know if you find anything..

    karliewharlien

    (@karliewharlien)

    The issue is resolved, and I´m to blame..

    The error code was casused by Ublock Origin.

Viewing 15 replies - 1 through 15 (of 19 total)
  • You must be logged in to reply to this topic.