Support » Plugin: Polylang » Error message: Declaration of PLL_Walker

  • Resolved ferreirajp

    (@ferreirajp)


    Hello,

    Today I have updated WordPress to the version 5.3 and also updated the Polylang plugin.

    I am now seeing the following message on my website:
    “Warning: Declaration of PLL_Walker_List::walk($elements, $args = Array) should be compatible with Walker::walk($elements, $max_depth, …$args) in /hermes/bosnaweb18a/b2975/ipg.fabulasticbluecom/ofppt/wp-content/plugins/polylang/include/walker-list.php on line 65”

    How can I solve this?

    Thanks,
    Jose

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • I have the same problem. Just upgraded WordPress and installed the Polylang plugin update. Same issue.
    Our page is here
    http://www.comibam.org

    Same problem here. WordPress changed the class definition for Walker, it now reads

    public function walk( $elements, $max_depth, …$args ) {

    before it was

    public function walk( $elements, $max_depth, $args ) {

    Since the Polylang PLL_Walker class extends that, you get an error. Should be a simple fix.

    Plugin Author Chouby

    (@chouby)

    Hello,

    This is fixed in version 2.6.7.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Error message: Declaration of PLL_Walker’ is closed to new replies.