WordPress.org

Forums

[resolved] Error message at Step 5 (8 posts)

  1. punstress
    Member
    Posted 8 years ago #

    Hi, I'm on Step 5. I got the following error message:

    Warning: require_once(/home/linda/public_html/blog/wp-includes/wp-db.php) [function.require-once]: failed to open stream: No such file or directory in /home/linda/public_html/blog/wp-settings.php on line 72

    Fatal error: require_once() [function.require]: Failed opening required '/home/linda/public_html/blog/wp-includes/wp-db.php' (include_path='.:/usr/local/php5-fcgi/lib/php') in /home/linda/public_html/blog/wp-settings.php on line 72

    I thought I followed every step so I don't know where it might have gone wrong ... Ideas?

  2. vkaryl
    Member
    Posted 8 years ago #

    "Step 5" of WHAT? The wp install has only 2 steps....

  3. punstress
    Member
    Posted 8 years ago #

    I should probably say that there is indeed a wp-settings.php file in the blog folder and at line 72 it reads:

    require_once (ABSPATH . WPINC . 'wp-db.php');

  4. punstress
    Member
    Posted 8 years ago #

    Step 5: Run the Install Script.

    Using your favorite web browser, visit wp-admin/install.php ...

  5. vkaryl
    Member
    Posted 8 years ago #

    Hmmmm. I've installed at last count 33 wp blogs, for myself and clients.

    I've never once got 5 steps. I get step one, then step two, which is "if you were expecting more, sorry to disappoint".

    Sorry, don't seem to be able to help you then.

  6. punstress
    Member
    Posted 8 years ago #

    Well here's the instructions I followed.
    Five steps.

  7. punstress
    Member
    Posted 8 years ago #

    I figured it out! For whatever reason, several files in the wp_includes folder didn't make it over when I FTP'd. I am double-checking now that I have each and every file.

  8. vkaryl
    Member
    Posted 8 years ago #

    Ah. Interesting. Didn't know that had been rewritten....

    I've never had the problems you're experiencing. I set up a vanilla db, create and add a user, then upload the wp distro, edit wp-config.php and upload, access wp-admin/install.php, click a couple of links, input a couple of things (blog name, email), and done.

    Not sure why you're having such a hard time. Just looking at the codex page you pointed to there, that's a lot of cruft for a really simple process.

    You might want to contact the folks at install4free - don't have the link handy, just do a search.

    [Edit: saw your latest post, good that you've sorted it....]

Topic Closed

This topic has been closed to new replies.

About this Topic