Support » Plugin: Molongui Author Box, Guest Author & Co-Author » Error message after upgrading to W5.7

  • Resolved sylvsteph

    (@sylvsteph)


    Hello,
    I upgraded to WordPress 5.7 and I see a double error line on the top of the admin pannel:

    Dans admin en haut :
    parameter 2 to be array, bool given in /…./molongui-authorship/includes/class-post.php on line 629
    parameter 2 to be array, bool given in /…./molongui-authorship/includes/class-post.php on line 629

    line 629 =
    $allowEdit = \in_array( $user->ID, \get_post_authors( $post_id, ‘id’ ) );

Viewing 1 replies (of 1 total)
  • Plugin Author Molongui

    (@molongui)

    Hi @sylvsteph,

    Thanks for reporting the issue! We have just released an new update (4.3.1) with the fix. It had nothing to do with WP 5.7 but PHP 8. So I assume you must be running that version of PHP.

    You should be able to have the plugin active without getting any error when browsing the Updates or Plugins page (from your Dashboard). So you should be able to get the update automatically —you might need to force WP check for updates (Dashboard > Updates > Check again). Or you can manually update the plugin. You could also remove it (version 4.3.0) and reinstall it (version 4.3.1).

    Either way, please remember to clear any cache after updating.

    I’m closing the ticket because I think the fix will work for you. If it doesn’t, please feel free to reopen it. And we will assist.

    Thanks again!

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.