WordPress.org

Support

Support » Installation » [Resolved] error message after upgrade

[Resolved] error message after upgrade

  • I’ve upgraded my blog from wordpress 2.3.3 to 2.5. Before I’ve deactivaded all plugins. After the upgrade I’m getting the following errors:

    http://thailand.xwsnet.de/

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /var/www/web778/web/wp-includes/widgets.php on line 1307

    Warning: Invalid argument supplied for foreach() in /var/www/web778/web/wp-includes/widgets.php on line 1307

    http://thailand.xwsnet.de/wp-admin/

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /var/www/web778/web/wp-includes/widgets.php on line 1307

    Warning: Invalid argument supplied for foreach() in /var/www/web778/web/wp-includes/widgets.php on line 1307

    Warning: Cannot modify header information – headers already sent by (output started at /var/www/web778/web/wp-includes/widgets.php:1307) in /var/www/web778/web/wp-includes/pluggable.php on line 689

Viewing 7 replies - 1 through 7 (of 7 total)
  • Can somebody help me with this problem?
    Or is somebody having the same error message in his wordpress?

    maybe this will help you

    I’ve just tried it, but I’m getting the same Message 🙁

    Wow, it works!

    I’ve just deleted the “*_wiget”-entries via phpmyadmin in the “wp_options” table of the database.

    For my deleting *_wiget”-entries is NOT working. I still have

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /var/www/xxx/wp-includes/widgets.php on line 654
    Warning: Invalid argument supplied for foreach() in /var/www/xxx/wp-includes/widgets.php on line 654
    Warning: Cannot modify header information – headers already sent by (output started at /var/www/xxx/wp-includes/widgets.php:654) in /var/www/xxx/wp-includes/pluggable.php on line 689

    on wp-admin page.

    Any other ideas?

    Best regrads

    Piotr

    Do you have a backup?

    If yes
    – restore it (files and database)
    – changing to default style
    – disable all plugins
    – at theme > widgets: delete all non default widgets
    – update to version 2.5
    – hope that it will work

    Good luck

    Ah ha. I have just had the same problem. nothing sugegsted was working.
    I was upgrading from 2.3 to 2.5.1. However, I was also moving domain. I did not want to do this upgrade on the current domain incase I got this error. So I had backed up the database and edited it manually before importing it into the empty database on the new domain.

    I opened widget.php in both the old domain and the new one and compared them. The 2.3 widgets.php was over 400 pages longer. I am not good at php in any respect. So to avoid editing anything, I replaced the widgets.php in my 2.5.1 installation with the widgets.php file from my old installation 2.3 and then went to upgrade.php and the errors are gone.

    Hope this helps someone 😀

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] error message after upgrade’ is closed to new replies.