WordPress.org

Forums

YOP Poll
[resolved] Error message after "save poll" (6 posts)

  1. kmand
    Member
    Posted 1 year ago #

    After creating a poll I get this error message:

    ( ! ) Warning: Illegal string offset 'schedule_reset_poll_stats' in C:\websites\insomnia\wp-content\plugins\yop-poll\inc\yop_poll_model.php on line 829

    ...then this:

    Call Stack
    # Time Memory Function Location
    1 0.0005 341968 {main}( ) ..\admin-ajax.php:0
    2 0.6151 33670776 do_action( ) ..\admin-ajax.php:72
    3 0.6151 33672288 call_user_func_array ( ) ..\plugin.php:406
    4 0.6151 33672320 Yop_Poll_Admin->ajax_edit_add_new_poll( ) ..\plugin.php:406
    5 0.6160 33683784 Yop_Poll_Model->edit_poll_in_database( ) ..\admin.php:7555
    Poll successfully Edited!

    So it works, but I would like to not get this message.
    I am using WP 3.6.1
    thanks!

    http://wordpress.org/plugins/yop-poll/

  2. droopy57
    Member
    Posted 1 year ago #

    Hi !

    in yop_poll_model.php on lines 829 & 969

    I replaced :
    if ( 'yes' == $yop_poll_options['schedule_reset_poll_stats'] )</em>

    by :
    if ( 'yes' == $request['yop_poll_options']['schedule_reset_poll_stats'] )

    And it works

    [Moderator Note: Please post code & markup between backticks or use the code button. Your posted code may now have been permanently damaged by the forum's parser.]

  3. droopy57
    Member
    Posted 1 year ago #

    Hi
    I can not edit my previous post
    Here the correction :

    in yop_poll_model.php on lines 829 & 969

    I replaced :
    if ( 'yes' == $yop_poll_options['schedule_reset_poll_stats'] )

    by :
    if ( 'yes' == $request['yop_poll_options']['schedule_reset_poll_stats'] )

  4. YOP
    Member
    Plugin Author

    Posted 1 year ago #

    Hi kmand,

    Edit yop_poll_model.php and on lines 829 and 969 replace

    if ( 'yes' == $yop_poll_options['schedule_reset_poll_stats'] )

    with

    if ( isset( $yop_poll_options['schedule_reset_poll_stats'] ) && 'yes' == $yop_poll_options['schedule_reset_poll_stats'] )

    and it should fix the problem.

    Best wishes,

    YOP Team

  5. jaroo
    Member
    Posted 1 year ago #

    i tried the last suggestion but the answers cannot be selected plus when you type info under the custom fields i created (name, email), you can only see top half of the text. it also has yellow dots on every field created.

  6. jaroo
    Member
    Posted 1 year ago #

    YOP Poll Archive Error Message

    Warning: Illegal string offset 'is_default_answer'......\wp-content\plugins\yop-poll\inc\yop_poll_model.php on line 3462

    Help!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.