Support » Plugin: Blackhole for Bad Bots » Error message

  • Resolved adjunctadvocate

    (@adjunctadvocate)


    Hi,

    I’m using WP 5.4.2 and the latest version of your great plugin. I downloaded my error log this morning and caught this:

    [29-Sep-2020 23:13:06 UTC] Invalid IP Address: Keep-Alive
    [30-Sep-2020 10:34:26 UTC] PHP Warning: fsockopen(): unable to connect to whois.arin.net:43 (Connection timed out) in /public_html/wp-content/plugins/blackhole-bad-bots/inc/blackhole-lookup.php on line 18
    [30-Sep-2020 14:23:33 UTC] PHP Warning: fsockopen(): unable to connect to whois.arin.net:43 (Connection timed out) in /public_html/wp-content/plugins/blackhole-bad-bots/inc/blackhole-lookup.php on line 18

    This is just an FYI in case Arin is now blocking redirected queries or something.

    Your plugin is working perfectly otherwise: blocking bad bots. sending email alerts, logging, etc…I do hope that you add the option of BLACKLISTING specific bots as well as your plugin’s ability to whitelist them. We have been trying to stop the SemrushBot and the AhrefsBot, in particular.

    Thanks so very much for your work. This plugin has cut down spam comments on our sites from hundreds per week to, maybe, twenty spam comments. It has blackholed dozens of bots and saved us megs and megs of bandwidth.

Viewing 1 replies (of 1 total)
  • Plugin Author Jeff Starr

    (@specialk)

    Thanks for the feedback. Glad to hear Blackhole is working well to cut down spam and save bandwidth.

    For the PHP warnings, current tests show that ARIN WHOIS is working normally, as far as the plugin is concerned. So it may be something specific to your site. I would keep an eye on it, but it should be nothing to worry about (ARIN goes down from time to time).

    Also thanks for the idea of adding blacklist functionality. I’ve added to the to-do list for a future plugin update.

Viewing 1 replies (of 1 total)
  • The topic ‘Error message’ is closed to new replies.