Support » Plugin: Simple Membership » Error message

  • Resolved Charles Rodmell

    (@charlesrodmell)


    Hi. When logged in, this works great. When logged out I get errors like: Stripe Subscription Error! Invalid source object: must be a dictionary or a non-empty string. See API docs at https://stripe.com/docs'Array ( [message] => Invalid source object: must be a dictionary or a non-empty string. See API docs at https://stripe.com/docs‘ [param] => source [type] => invalid_request_error )

    Any ideas? Cheers.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support mbrsolution

    (@mbrsolution)

    Hi, did you follow the following instructions?

    Regards

    • This reply was modified 9 months, 2 weeks ago by  mbrsolution.

    The buttons used to work. I’ve had signup from them. Has something changed? I can recreate them again if so.

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi, do you know what has changed in your site before the buttons stopped working? For example, did you update any other plugin? Did you update your theme? Where there any changes made to your server?

    Regards

    Probably a few changes to plugins and wordpress version. I don’t think any changes have been made to the server, but can’t be sure. I have just tried recreating the button and checking all my live stripe keys are correct but the same result. I also tried deactivating all plugins except this one but it did not help. The only thing I haven’t done yet is update to the latest version of my theme (Divi). Any recommendations for next steps? Thanks. Charles.

    Plugin Author wp.insider

    (@wpinsider-1)

    What happens if you delete the subscription plan in your Stripe account then recreate it and connect it to a payment button in the plugin?

    No change. I deleted a plan and its product completely and then tried again with a new button in the plugin and placing the new button on the page (“web mastery”). Works fine when logged in. Error message (as per OP) when logged out.

    Plugin Author wp.insider

    (@wpinsider-1)

    This is a little strange. I can’t think of any reason for this. I tested the stripe checkout couple of times in my site just now and it works.

    Is it conflicting with another plugin or theme on your install?

    Good point, I’ll try with a default theme later and let you know

    Sorry to waste your time. It must have been a caching thing while testing…. Once I disabled all plugins and deleted cache, I was able to narrow it down to the EU Cookie plugin which was blocking scripts. All sorted now 🙂 Keep up the great work.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Error message’ is closed to new replies.