WordPress.org

Forums

Responsive Image Widget
Error message (10 posts)

  1. AmberEM
    Member
    Posted 1 year ago #

    Hello there,

    I thought your plugin might be the answer for one of my clients, however when I tried it out in sidebar, an error message displayed in the sidebar, with the image displayed below it. Here is a screenshot of the message:

    http://www.atlas500000.co.uk/wordpress/wp-content/uploads/2013/07/resp-img-error-msg.jpg

    The only data I entered into the widget was the image URL (i.e. no title or anything else). Could this have caused any issues? I am using a child theme of the Responsive theme. I inserted the widget into the sidebar of the inner part of the site (not the homepage).

    Thank you so much,

    Amber

    http://wordpress.org/plugins/responsive-image-widget/

  2. pillboxhunter
    Member
    Posted 1 year ago #

    I am having this as well. On the test site hosted by fat cow it works perfectly but on the live site it generates the error message - Warning: getimagesize() [function.getimagesize]: URL file-access is disabled in the server configuration in /homepages/28/d387438888/htdocs/cumberland/wp-content/plugins/responsive-image-widget/responsive_image_widget.php on line 98

    Warning: getimagesize(http://www.cumberlandarms.co.uk/cumberland/wp-content/uploads/2013/07/wifi.png) [function.getimagesize]: failed to open stream: no suitable wrapper could be found in /homepages/28/d387438888/htdocs/cumberland/wp-content/plugins/responsive-image-widget/responsive_image_widget.php on line 98

    Warning: Division by zero in /homepages/28/d387438888/htdocs/cumberland/wp-content/plugins/responsive-image-widget/responsive_image_widget.php on line 99

    if i move the image to the root and enter the url as just the filename I get the image but no control over it's size. any ideas?

  3. pillboxhunter
    Member
    Posted 1 year ago #

    Live site hosted by 1 and 1

  4. benarobinson
    Member
    Plugin Author

    Posted 1 year ago #

    I'll look into it, thanks for letting me know. Might be a PHP version issue.

  5. benarobinson
    Member
    Plugin Author

    Posted 1 year ago #

  6. benarobinson
    Member
    Plugin Author

    Posted 1 year ago #

    It's a PHP permissions issue for the image size function, 1and1 is not letting that function run (the function gets the height and width of the image). Try what they suggest at that link above:

    Basically, you just create a text file with a filename of "php.ini" and save it in the main directory of your WordPress install. And its content should have the following:

    allow_url_fopen = ON

    So, make a text file in notepad, put that single line and save it as php.ini, then put it in your WordPress install folder (probably httpdocs or public_html).

  7. benarobinson
    Member
    Plugin Author

    Posted 1 year ago #

    PS: The solution above is a workaround that will probably work, but I'll try to get a better solution built into the plugin in future updates.

  8. benarobinson
    Member
    Plugin Author

    Posted 1 year ago #

    Also, I think this issue may be solved by using local rather than remote files.

    In other words, you should upload your file to your own media library rather than using a file hosted by someone else (in the case that your server gives you this error.)

    Again, I will post an update in the future which will avoid reliance on this function, but the best practice is always to use a local rather a remote file for other reasons too -- a remote file hosted by someone else might be taken down!

  9. RustyWood
    Member
    Posted 1 year ago #

    Hi I'm getting the same error, it was working perfectly fine yesterday!
    I tried using the php.ini file but with no luck
    Thought I would let you know
    Thanks
    Rusty

    Warning: getimagesize() [function.getimagesize]: URL file-access is disabled in the server configuration in /home/c*******/public_html/word/wp-content/plugins/responsive-image-widget/responsive_image_widget.php on line98

    Warning: getimagesize(http://word.c*****************.com/wp-content/uploads/2013/08/Beauty-01-Photographer-J****-*****.jpg) [function.getimagesize]: failed to open stream: no suitable wrapper could be found in/home/creation/public_html/word/wp-content/plugins/responsive-image-widget/responsive_image_widget.php on line98

    Warning: Division by zero in/home/c******/public_html/word/wp-content/plugins/responsive-image-widget/responsive_image_widget.php on line99

  10. benarobinson
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Rustywood,

    Is your image hosted locally on your own site, or somewhere else? Did you change images at all before the message? Let me know on those two things.

    I believe that the issue is caused by the permissions at a server level regarding the execution of the getimagesize() function in PHP, so it could be something that your host changed recently. Who is your host?

    Let me know and I'll see if I can track it down and give you another workaround, I think I may need to use CURL to convert remove URLs to local ones to fix this in the next update.

    You can email me personally at ben@keokee.com with your URL and I might be able to look at it more directly -- I realize you may not want to share that with the general public yet.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Responsive Image Widget
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.