Support » Plugin: GeoIP Detection » Error: Maximum execution time of 300 seconds exceeded

  • Hal

    (@halburgissnet)


    I am trying to run the ‘Update Now’ action and keep getting timeouts. There is a large 57M file downloaded. Is there any way to know if I got the whole thing and its not corrupted or missing data? After the attempt I am getting this, which looks suspicious:

    Selected data source: GeoLite2 City database (updated monthly)

    Database file: wp-content/uploads/GeoLite2-City.mmdb
    Last updated: June 5, 2019 2:18 pm
    Database data from: June 3, 2019 11:31 am
    Next update: April 11, 2186 7:28 pm <<<<<<<<<<<<<<<<<<<<<

    Running a couple of test lookups, all seem to be ok.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author Benjamin Pick

    (@benjamin4)

    April 11, 2186 – wow, interesting!
    You can reschedule by using a different user (like Maxmind Manual) and then re-selecting the automatic update option.

    The file should be ok because he starts extracting only after downloading the whole thing, and if he doesn’t finish extracting, he will re-extract it without downloading it again – this should be doable even in bad shared-hosting conditions. But yeah, I don’t know if the Maxmind lib checks the integrity of the file before using it (I don’t think so as it’s designed for fast lookup).

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.